GL-MT300N-V2 does not repeat if the internet provider does not have WDS activated


#1

I recently purchased the GL-MT300N-V2 model, it seems very good equipment, but when trying to repeat the signal from my internet provider, it does not succeed, since it does not associate me with any IP, gateway, or DNS. I contacted my provider and he told me that his computer does not have WDS activated, and if he does not have it activated, my GL-MT300N-V2 can not repeat, nor in WISP mode, my question is: is this true? Is there any manual configuration I can do to make it work ?, I can not change the provider since it is the closest and the others, despite having the WDS activated, are very far from my location, could you help me? Thanks in advance.


#2

WDS does require the upstream router to have support for it, but WISP should work fine. The MT300N will connect as any other client to your ISP, and any clients then connected to it will have internet.


#3

Thank you for responding so fast, I think you can not explain me well, my internet provider does not have DHCP enabled, users must place the data manually: DNS, gateway, and IP, so when I connect with WISP, it does not happen nothing, connects well, but I do not get IP, or DNS, or gateway, so I do not have access to the internet or LAN, or wifi, as I can configure manual ???


#4

Could you give me some more info please?
How is your MT300N connected? Are you connecting to a lan connection for the internet? Is it going into a gateway from your ISP? What is required to connect to your ISP? PPOE?


#5

Thanks again for answering so fast, I will try to be as specific as possible: my Internet provider for “security” reasons, has not activated DHCP, or WDS, usually connected via wifi, but should assign the IP, Gateway and DNS manually, so I had internet on my PC, but if I wanted to have connection on my smartphone I used a software to enable the hostpot (connectify) and all good: I had internet on my PC and my smartphone, I decided to buy the GL- MT300N-V2 for its good features and price, I connect my new GL-MT300N-V2 via LAN to my PC, I put it in repeater mode, I connect to my provider and nothing happens, I do not have internet neither in my PC nor in the devices that connect to my computer via wifi, I do not even give PING to the gateway. My question is: is there any way to manually enter the data from the advanced options ?.


#6

Right Ok. So what you will have to do is open the “Advanced Settings” at the top right of the UI. This will take you to Luci. Log in there, go to Network -> Interfaces. You will see an interface called WWAN. It should also say “Client” and the name of the wifi from your isp. Click Edit, and change protocol to Static address, and set your information there :slight_smile:


#7

Thank you very much again, doing what you say to me already I must have internet on my PC through LAN and the devices that are connected by wifi to my computer?


#8

There is a lot of guessing what exactly your ISP is providing. E.g., are you actually connecting to your ISP via Wifi? Or via ethernet? In either case, since you are assigned a specific IP (a public IP? or private? Do you need us to tell you what a private IP looks like?), repeating is not going to work. You will need to route instead.

Since you get only one IP (according to my guess), you can connect only one device directly to the ISP. Presumably, you want to connect your MT300N to the ISP (preferably via ethernet) and connect both your PC and your smartphone to your MT300N via Wifi.

But I am only guessing. Maybe you are assigned several IPs by your ISP? How many?


#9

Sorry if I look like a novice in this topic, but I would like you to clarify the correct configuration mode, as mentioned previously, my ISP has not activated DHCP, I connect via wifi, my configuration is like this:
My IP: 187.88.8.28
Gateway: 187.88.8.1
DNS: 181.225.231.120
I put a hotspot software and I already have internet on my pc and the mobile
what I want is to connect my GL-MT300N-V2 via LAN to my PC, I configure it in repeater mode with WISP. My question is: How do I configure everything so that I have internet on my PC via LAN, and in turn repeat it by WIFI? please I need your help to configure it with the data that I wrote previously.


#10

You have a single public IP assigned to your PC (iiuc). You cannot (usefully) repeat this via WiFi, but you can route it on your PC. If you have a Real OS™ (anything but Windows) on your PC, then this is straightforward - but the question is about configuring your PC instead of configuring the Gl.inet.

If you are running Windows, or don’t want to mess with your PC much, then you will have to connect the Gl.inet to the ISP (via the ether port on the Gl.inet labeled “WAN”) instead of the PC. Connect your PC to the Gl.inet via the ether port labeled LAN.

Configure your PC to use DHCP instead of the fixed IP. The Gl.inet will assign it a private IP in 192.168.8.* by default. The Gl.inet will be at 192.168.8.1 by default on the LAN port on the Gl.inet.

Configure your Gl.inet with the public IP and DNS settings you gave above. Configure the wifi with a wifi password and you are set. The Wifi on the Gl.inet is bridged to the LAN ether port by default. (If you tried to change the Wifi to client mode via the previous instructions, you will have to change back to WAP mode.)


#11

Continuing what we talked about. You can start with no internet on your pc, to make sure it works. Then connect your pc to the router with a lan cable, log in to the UI. In the UI connect the repeater to your ISP wifi, and then follow what i wrote you before.

So you basically enter the IP, gateway and dns into the static address in WWAN.


#12

AIUI, he currently connects his PC to the ISP via ethernet, not Wifi, and manually configures a single public IP.


#13

BTW, if your ISP uses a cable modem, when you move the public IP from your PC to the Gl.inet, you may need to reset the cable modem in some way before it will recognize the new MAC address.


#14

that’s the problem, I can not connect to my ISP by cable, it has to be by wifi, so what I need is to connect to my ISP via wifi with my GL-MT300N-V2, connect it by LAN to my PC, and that of this so I can have internet by LAN on my PC and by wifi on my smartphone


#15

@androidcuba I understood, follow what i wrote above.


#16

Good morning, I did what you suggested, thank you very much for answering, configure the data in WWAN, but still does not assign IP to my smartphone, when I try to connect to the wifi it stays “opting IP” and does not connect, What I can do???


#17

Were you able to get an IP on your pc via Lan? Did the internet work?


#18

Neither, in my PC I do not obtain IP, in fact I can not enter the router, however if I connect to the public Wi-Fi of a hotel if I opt for IP, and I repeat the connection for the PC and the smartphone, but the wifi publish if you have activated the DCHP, but as I mentioned my ISP does not have DHCP enabled and I must put it manually, I did it from Luci, but I do not get IP on the smartphone, it stays getting IP , and it does not connect, and I do not have internet by LAN, how should I configure the repeater in Luci?


#19

Are you still trying to use WDS for some reason?

I ask because in WISP, the router will use the static ip to connect to your ISP, but at the same time, it has it’s own IP range that it gives to any computers connected to the Wifi and LAN ports.


#20

I apologize if it takes time to write, but I am testing the settings on my computer and I run out of internet, I can not use WDS because my provider does not have it enabled,