GL-MT300N-V2-ec6 won't connect to WiFi in repeater mode

The GL-MT300N V2-ec6 running Version 3.102 firmware setup in repeater mode does not automatically connect to wifi at boot. The SSID and password are saved properly.

If I select the remembered WiFi network SSID and press [Join] the message “wifi not in range” will be immediately displayed.

If I select the Scan link in the Repeater section of the SSID will be found and I can connect by entering the password.

I would like the MT300N to connect to the saved wifi on boot. Any recommendations on how to resolve this problem?


Do you have many of the same SSIDs around you?

This morning I located the issue and this is resolved. Here is the background information.

Internet connectivity is provided by a Cellular to WiFi hotspot. The GL-MT300N-V2 (Mango) subscribes to the SSID provided by the WiFi hotspot. I then have various devices attached to the LAN port. My application does not need a WiFi hotspot provided by the Mango and so I turned that functionality off. By turning off the 2.4G WiFi hotspot, the Mango will no longer connect automatically to Internet WiFi connection.

To resolve this issue I re-enabled the Mango 2.4G WiFi.

To protect the Mango 2.4G WiFi from being accessed by clients, since I cannot disable it without disabling the bridge connection to the cellular hotspot, I hid the SSID and gave it a long random password.

OpenWRT should allow one to subscribe to a WiFi gateway and not enable itself as a WiFi hotspot.

Thanks for replying so promptly and I hope you have a great day.

1 Like

in gladmin web\ internet click on “repeater options” and set to autoconnect
in gladmin web\wireless if there is a green dot under 2.4gzh tab click the “on” button on the far right and wait for it to turn off.
then edit router from rj45 jack

I tried those settings prior to my initial posting. I’ve tried them again. Upon reboot, OpenWRT does not reconnect to the WiFi gateway subscription.

When the web/wireless setting for 2.4GHz is enabled, the Mango will connect to the Internet WiFi subscribed SSID. I suspect a bug, however, I can work around it.

if you were to reword that with something like:
if you disable “ap” on mango then wisp does not work with wpsk2

wifi gateway subscription makes one think were not using the same terminalogy

Yes, if one disables the AP on the Mango then the wireless ISP connection no longer automatically connects on boot. One must initiate a scan, locate the wisp SSID and enter the password. If the AP on the Mango is NOT disabled, the wisp automatically reconnects at boot.

latest testing version is 3.104
try a factory wipe and see if that fixes it.

1 Like

I guess this is probably due to the fact that 300N-v2 uses MTK private WIFI drivers instead of using openWRt’s open source drivers.

this router is different from other gl routers with MTK driver. there isn’t even a wireless tab in luci-network-wireless.