GL-MT300n-V2 firmware v3 update


#1

Hi GL-iNet Developers and Everyone Else,

Well, I am impressed with the new firmware v3.xx update. Thank you for a good firmware upgrade.

I was nervous about updating to this firmware v3.xx because the last firmware update 2.27 killed my minidlna UPNP server that was working before.

Then, after updating to this new firmware v3.xx I could not access the router’s menu anymore although I had access to the Internet, so the update reset the network mode. So, after a mild panic attack, I unplugged the router and plugged it back in, still no menu access. I reset the router a couple times, short reset, long reset, still could not access the router’s menu. Then I reset it again for about 10 seconds, then I could finally access the new router’s menu with firmware v3.xx.

I had to re-configure my Admin login password which works now, and create a new WiFi connection to the parent router with a new WiFi password, etc… And it all works great.

And, I could easily search for “minidlna” and add the application plugins for minidlna, luci-app-minidlna, luci-i18n-minidlna-en (english), and now the router functions perfectly again as a portable DLNA server streaming multimedia content (videos, music, pics) from a USB Stick or a USB drive.

I was never able to get the previous UPnP/DLNA option to work in previous firmware versions, is that because of the parent router’s settings?

What happened to the “wisp” option, is that now part of the “router” network mode? And what happened to the previous UPnP option?

Best regards,
Phil D (phd21)
phd21mint@gmail.com


Something wrong?
#2

UPnP had been remove from v2.27. You can try port forwarding in v3.0.

For how to use WISP, you should read this article. https://docs.gl-inet.com/en/3/setup/mini_router/internet/#2-repeater


#3

Hi kyson-lok,

Thank you for replying.

Re: Wisp and the link you provided.

My router’s firmware v3 does not match that links description.
Under the Internet heading I have

Name of a connection to the parent router using WiFi, but it does not say repeater mode anywhere
Cable
Tethering
3g/4g modem

Under Network Mode I have
Router
Access Point
Extender
WDS

Regards,
Phil (phd21)


#4

Which browser are you using for? Are you trying this on your Phone or PC?


#5

Hi kyson-lok,

I am using the Slimjet browser from my Linux KDE Neon PC (Dell Optiplex 780)

Be aware that you may not be able to access the web Admin Panel with the default IP 192.168.8.1 if you use the router in Access Point , Extender or WDS mode. If you want to access the web Admin Panel in this case, you have to use the IP address assigned by the main router to the GL.iNet router.

How would someone find out what IP address the GL router was assigned to access its menu in these modes?

Thank you,
Phil (phd21)


#6

image

It seems that it works in WISP mode, isn’t it?

You should find its IP address on your upstream router.


#7

Hi kyson-lok,

The router seems to be working well with the new firmware v3 update. I guess it is in repeater - wisp mode, but it would be nice if it showed that somewhere on the screen.

How would someone find out what IP address the GL router was assigned to access its menu in these modes?

It would be almost impossible to determine what IP address was assigned to this router from an upstream router without some help especially if you do not have access to that upstream router like with public WiFi, or where someone else has control of the upstream router. There should be some method to find out what IP address was assigned or some way to access this router’s menu when in the other network modes. Don’t you think?

Just a thought, maybe if the user was able to put in their email address in this router’s setup, then if the router was switched into a non-repeater network mode this router could send an email with whatever IP address was assigned by the upstream router or by sending some form of network message that displays to any connected client the router’s assigned IP address, so that we could access this routers menu?

Best regards,
Phil (phd21)


#8

Network mode means bridge mode. In general, if someone wants to use bridge mode, it means they need to build a big subnet, the main router should be controllable.

Connecting to public WIFI, you may just want to access the Internet, it shouldn’t be bridge mode.