GL-MT300N-V2 + WireGuard (Mullvad) = Starts slow


#1

Hello,

I have the GL-MT300N-V2 and I set Mullvad WireGuard up and it is working.

The propblem at a speedtest ( for examplae nperf.com ) :slight_smile:

It starts at 2-3 MBit/s and after 30s+ if accelerates to 60MBit/s ( real Uplink 60 MBit/s).

So it’s not possible to watch IPTV.

My question:

Is there a setting to get fullspeed without the gap?

Thank you very much.


#2

not sure what you mean. is the speed 2-3 Mbps or 60mbps?

Can you try another Mullvad server? Wireguard can achieve 40+Mbps on this router.


#3

It’s only 2-3 MBit/s with GL-MT300N-V2 and I tried every Mullvad server.

And every time I tried it with my laptop, there it works - 60 MBit/s.

I hoped to get higher speeds with WireGuard, but even OpenVPN is ~ 10 MBit/s :slight_smile:

I would really need WireGuard :-/


#4

I just tested using my AR750 and I can get 17Mbps using Mullvad Wireguard when testing from Hong Kong to Singapore (I have 10Mbps upload limited).

I am not sure what is wrong with your test. Did you see this post and check if you have mtu_fix=1?


#5

Hello,

now I have a second device --> GL-AR750S-756

It is the same … 2-3 MBit/s

I will try your advice with mtu-fix and after I tried it I will answer you.

Thank you.


#6

I added
uci set firewall.wireguard.mtu_fix='1’
to the /etc/init.d/wireguard script

… and it is still the same. Just 2-3 MBit/s :frowning::sob:


#7

With OpenVPN and Mullvad or AirVPN I have ~ 14-15 MBit/s …

So even OpenVPN is faster than Wireguard !?


#8

If WireGuard would run, I would buy 15 MT300N-V2 (Mango) and 4 AR750S-756 …

… only because of the WireGuard support. And some business partners would use the devices in their office.

If WireGuard does not work and if it is still beta and not stable 1.x then it’s, sorry to say that, a small toy. But with WireGuard stable working you could find thousands (1000s) of customers in Europe!

I have sold the Mango, it’s too slow. The AR750S-756 / Slate is quiet okay with OpenVPN ~12-14MBit/s … but if WireGuard won’t work I’ll sell it, too.

I really, really would love to see it working. It’s a great product.


#9

I actually got a lot of feedback about speed. Most of the cases wireguard achieved a very good speed. In some cases it is still not and I am not clear of the reason.

Did you reboot the device after changing mtu_fix?


#10

Yes, I rebooted after changing mtu_fix. 2, 3, 4 times :slight_smile:

But now I’m focusing at the following fact …


Same WireGuard Provider :
Mullvad
and
An own WireGuardServer with 1000 MBit/s U/D)

Same Internet provider, same router

WireGuard on my smartphone / Android (= Linux) … FullSpeed: ~25 MBit/s
WireGuard on my AR750S-756 / Linux … FullSpeed: ~ 2 MBit/s

Both are linux-based, so the OS is “similar” …

My smartphone is rooted and I disabled IPv6 on it! = FullSpeed: ~25 MBit/s
My AR750S-756 has IPv6 enabled = FullSpeed: ~ 2 MBit/s

I tested both devices ( smartphone / AR750S-756 ) at the some uplink / router and this one hast “DS-Lite”, so it’s connecting through IPv6 and tunneling IPv4 ( if I understood correctly).

But if there is an IPv4-Only device, it works of course, because of that IPv6/IPv4 tunneling.

Fact: My smartphone is now an IPv4-Only device, because I disabled IPv6 on it.

Question / Suggestion : If I would config the AR750S-756 like my smartphone, then it should work with WireGuard perfectly.

But how / What to do?

Other possibility : I’m using WireGuard for Android v0.0.20181218 an there it works.

So maybe the reason for low speed is an old WireGuard version. I think I read about WireGuard Beta an the GL-INET firmware.


#11

Could you please PM me your WireGuard configuration? So I can connect to it, and check this issue.


#12

I did so.

Thank you.


#13

I paid now for AzireVPN subscription and tested threir WireGuard …

… it’s the same! Only 1-2 MBit/s.

BUT: Upload allways full 3 MBit/s !

Forgot to mention : My Max Upload is 60 MBit/s and Upload is 3 MBit/s


#14

Is there anyone else who has or had the same problem?


#15

AzireVPN still the same?


#16

Yes.

On my Android device I have “Wireguard for Android” + Mullvad/Azire and I have there ~ 30MBit/s

On my IPTV box (android) I can watch FHD streams with at least 15-25 MBit/s and it works.

It seems that it works perfectly with android devices. But why?


#17

Not sure why, but will continue to investigate this issue. For my testing, only Mullvad is slow, AzireVPN is faster than Mullvad. The CPU of Android is more powerful than router, so the speed will faster than router, it is make sense.

But… in this case, the CPU is idle, while the speed is slow. It isn’t caused by CPU.


#18

Sure. But my IPTV box has a really poor cpu, but openvpn is faster than wireguard.

What client are you using at windows?

I’m using TunSafe. And it shows me, when I’m connecting and starting a download following data …

Overhead : 10.089% IN - 128.221% OUT
Packetlos : @ idle 18.322% / @ download ~30%

This data doesn’t seem to be normal?


#19

The smae, I use TunSafe(v1.4.1). I test it via speedtest.


#20

I found out why the WireGuard from the WG developers is much faster.

TunSafe has a setting for the MTU and the field shoes “auto”. The speed is 1 MBit/s.

I played around and found out, if I set the MTU to 1300, that I get nearly the same speed!

I’m not familiar with openWRT : What exactly does the xxxxxx.wireguard.mtu_fix = ‘1’ ?

Is there a possibility to change the MTU from the slate to 1300 ?