GL-MV1000 brume vanilla openwrt support

thank you marcz I flashed via uboot but not response via ssh or http on and no dhcp server. boots to a solid power light but that’s all.

did you unplug the cable to renew dhcp lease?

yes and unplugeed power cable too and since I was flashing image static used for client should have been ok too I guess. I did come from 3.104 adguard version. nor/nand issue. this box is different from the other devices i’m used.

I flashed from the glinet web ui without problem.

false alarm working now. not sure why but happy. thanks!

1 Like

Ok , I’m glad it worked.

would love to give some feed back on your sharing but please don’t take this negatively. just posting so others who choose to try out your build know what else is built in.

adblock, okay with 500mb of storage use in emmc use it or leave it space is not an isue.
nextdns, I like it and use it but noticed when you uninstall it there is still residual traffic from the router to and since it’s built it cant’ be removed.
ttyd, gives me the creeps :wink:
openvpn, yes
vpnbyepass, I use vpn-policy-routing and love it. my deal breaker since I can’t uninstall and you cant have both installed.

Following your suggestions I built an image with only luci, all packages installed are in the .manifest.

1 Like

been using image for a while now works great. the one thing I could never get working was my dlink dwa-171.
I installed

I then removed kmod-rt-8812au-ct and tried the alternate driver of
kmod-8xxxu without luck also.

“iwconfig” does not yield a wlan0, and I have tried deleting /etc/config/wireless. and I can’t see it with lsusb
any ideas greatly appreciated.

For the dlink dwa-171 I have installed kmod-rtl8812au-ct hostapd-common wpad-openssl , after setup the WiFi a reboot is needed to work properly.

1 Like

Let me first say this may not be the place for this questions since it is about vanilla openwrt but does hold some merrit since it’s on an mv1000. So I decided I may be interested in using ttyd. I flashed your patches with minimal plugins but now I want to get ttyd working. I install luci-app-ttyd and enabled with defaults and tried configuring with no luck. in your first mv1000 image ttyd worked perfect straight from flash

  1. did you add a modified config file to your image? (/etc/config/ttyd)
  2. the default port is 7681, if connected via the web page does this port need access to it extenally by opening port 7681 or is it all done from within the web interface scripting. also I am only using https.

any pointers greatly appreciated.

Hello GL-Inet Team. For the past few days I have been studying GL-MV1000. For my tasks, I need to install the latest version of OpenWRT(trunk) on it. And I need to install it on the internal 16Mb NOR storage. I build the OpenWRT image with squashfs and flash it to NOR. But the U-Boot, when trying to load kernel from the NOR, gives the following message:
Uncompressing Kernel Image … Image too large: increase CONFIG_SYS_BOOTM_LEN

Could you please recompile your U-Boot version for MV1000, specifying the CONFIG_SYS_BOOTM_LEN option(32Mb or more) so that I can use the NOR storage to load latest OpenWRT image?


Hello, is there a mirror package for mv1000w?

The flash is size of 16M by default for MV1000.
Did you change the hardware(nor-flash size)? If not,the kernel image with nor-flash you compile is too large,it may not be working propely.
And how did you build such big kenel?

The MV1000W image url is:

Hello. My gzipped kernel size is only 3Mb. But when U-Boot try to ungzip it to RAM, RAW kernel size is 10Mb.
If CONFIG_SYS_BOOTM_LEN is not explicitly set, then its default size is 8 megabytes and the kernel(10Mb) does not fit into these 8 megabytes when unpacking. So I ask you to increase the CONFIG_SYS_BOOTM_LEN value to 32 megabytes (with a margin for the future).

And yes, I change Makefile to get legacy OpenWRT squashfs image(for NOR).

define Device/glinet_gl-mv1000
  KERNEL_NAME := Image
  KERNEL_LOADADDR := 0x000080000
  KERNEL := kernel-bin | lzma | uImage lzma | pad-dtb
  DEVICE_PACKAGES := ethtool kmod-usb2 kmod-usb3 kmod-usb-storage
  BLOCKSIZE := 64k
  IMAGES := sysupgrade.bin
  IMAGE_SIZE := 15000k
  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
  DEVICE_DTS := armada-3720-gl-mv1000
  DEVICE_DTS_DIR := $(DTS_DIR)/marvell
  SOC := armada-3720
TARGET_DEVICES += glinet_gl-mv1000

HI adron,
1,MV1000(kernel) start from EMMC by default.So,if you want to start from nor-flash,you need set env on uboot:
set bootcmd ‘run boot_mtd’

2,I have compiled a firmware of uboot.CONFIG_SYS_BOOTM_LEN havs been modified to 64M.
You could update the uboot after unzipping the firmware of (320.7 KB)

1 Like

Thank you very much!

a little question:

how difference is MV1000 vs MV1000W?

is rom for MV1000 ALWAYS can be flshed into MV1000W? (then add back the driver
for wifi?, i.e. MV1000W is a perfect superset?)


MV1000 and MV1000W use the same firmware. The firmware detects if there is wifi or not.