GL-MV1000 brume vanilla openwrt support

How to flash in uboot

I want to know how to compile the gl-mv1000w firmware from the openwrt source code, which components and plug-ins need to be selected. Is it convenient to provide a config.buildinfo file

You need to choose mvebu/cortexa53/ and find mv1000 as target

precompiled firmware can be find here
https://downloads.openwrt.org/snapshots/targets/mvebu/cortexa53/

No .config file can be provided

and then? How to brush? I use u-boot to flash the machine and no response

gl-mv1000w怎么在openwrt官方系统加入wifi驱动

Sorry for necroposting but I just tried these (more recent) files in uboot and ended with nothing usable.
How are we supposed to use these files ? Why does someone even care to generate them if there are no install instruction anywhere ?

I was very appreciative to get a head start on vanilla openwrt and so did others. one can take two directions. one being the following:

  1. hey this looks great guys thanks for posting. I’m a little rusty (very) and I was wondering if someone could take the time to help me out im stuck and i would greatly appreciate it.

or
2. dam you mofo’s postin shit on the internet messin up my stuff that don’t work your crap stinks and it’s a waste of my time.

yeah your name fits you. take it elsewhere

1 Like

for wifi a used a tplink tl-wn722n usb wireless with it. (I had to install drivers) and they were compatabile with wpa3 :wink:

Flashing to vanilla worked for me. Here are some more concrete instructions:

  1. If you’re attached to your config, save a backup first, as this procedure appears to blow it away.
  2. I followed gl-inet’s How to Enter the Uboot Web UI instructions. I had to try a couple times with the reset. The time it worked, I power cycled right before holding down the reset button. Not sure if that was necessary. But as it says on that page, I had the WAN port unplugged and the LAN port going to my machine, which I gave a fixed IP 192.168.1.2. I was able to connect to 192.168.1.1.
  3. From the uboot UI, I flashed glinet_gl-mv1000-squashfs-sdcard.img, which I’d downloaded from the snapshots URL mentioned above and ungzipped.
  4. The brume stopped responding to pings then started again after (iirc) 15 seconds. I waited a few minutes for a web interface but it never came up. Eventually I port-scanned it and realized ssh was open.
  5. I logged in via ssh -o UserKnownHostsFile=/dev/null root@192.168.1.1, plugged in the WAN port, and ran opkg update && opkg install luci as mentioned in the openwrt docs. Then the web interface came up.

Now my brume is running OpenWrt SNAPSHOT r17122-6721c20629 / LuCI Master git-21.194.64526-f919635.

I realize now there’s a real release candidate (not a snapshot) at https://downloads.openwrt.org/releases/21.02.0-rc3/targets/mvebu/cortexa53/. Doesn’t look like there are any release builds for the 19.07 branch.

4 Likes

Is anyone using vanilla OpenWRT 22 on Brume? How is the hardware support?

I’m using one of the wifi dongles suggested by GL-inet, it’s based on rtl8812/8821, I understand that may not be supported. But how about other stuff? Problems?

I didn’t try openwrt 22 recently. But it should be pretty stable on MV1000.

Even if you add wifi dongle, it should be pretty easy to install drivers and make it sta.

make it sta.

Do you happen to have insight on which if any dongles work well for AP mode in recent vanilla OpenWRT? Especially dual-band ones.

Updating to add that I’m currently testing Mediatek MT7610U based dongles, but, I’m testing them on Shadow so it’s in a different thread. GL-AR300M Shadow 5GHz dongle?

When building the target image for my MV1000 using OpenWrt git for 22.03, what settings would you typically use for the highest expanded size to use for squashfs so I don’t have to expand it later?

(16)Kernel partition size in MiB
(?) Root filesystem partition size in MiB
I was going to use something like 6675 MiB or should I do more?
-Any additional packages recommended? I kinda want my led’s to function and USB.
-Any extra tips or tricks?

The size seems ok. For usb, choose as much as possible, e.g. storage, etc.

1 Like