GL-MV1000 web interface not accessible

Hello all,

just bought a GL-MV1000 and it’s an awesome little device.
I configured a lot of stuff in openwrt, and I don’t know what I did but now I can not access the main gl interface on
If I open the browser javascript console I see
TypeError: "this.router_vpn['Shadowsocks-Client'] is undefined"

Can I fix this?
I could reset the router and start fresh, but I don’t know what I did that broke it.

Hi, You can go to the following link to download the latest test version firmware (3.102) and see if there are still problems, thank you

Thanks for the reply. How do I apply this firmware without access to the main web interface? Can I somehow do it from the command shell?

Edit: ok got it: there is a menu inside openwrt. Flashed the new image
3.102 openwrt-mv1000-emmc-3.102-0215.img 41067db05ee7614d85068adf6af1467e
It works now!

After updating to the testing image, it seems that software packages in openwrt are somehow broken?
Tried to install unbound, but I get this error:
Is there a distfeed missing?
In the list is

src/gz glinet_core
src/gz glinet_base
src/gz glinet_gli_pub
src/gz glinet_packages
src/gz glinet_luci
src/gz glinet_routing
src/gz glinet_telephony
src/gz glinet_glinet

Hi ,Simon
This colleague who we developed later will reply to this question

Hi , Simon
I’m sorry to reply you so late. There are compatibility problems between this module and the testing firmware(3.102 openwrt-mv1000-emmc-3.102-0215.img 41067db05ee7614d85068adf6af1467e).
Later, the official firmware release will fix this problem.

You need to perform the following steps:

ssh root@
opkg remove luci-base --force-depends
opkg remove luci-proto-ipv6 --force-depends
opkg remove luci-proto-ppp --force-depends
opkg update
opkg install luci-app-unbound

ssh root@ and copy to MV1000.
After decompressing (10.0 KB)
cp luci/status.lua /usr/lib/lua/luci/tools/status.lua
cp luci/lease_status.htm /usr/lib/lua/luci/view/lease_status.htm
cp luci/wifi_assoclist.htm /usr/lib/lua/luci/view/wifi_assoclist.htm
cp luci/sys.lua /usr/lib/lua/luci/sys.lua
cp luci/firewall_zoneforwards.htm /usr/lib/lua/luci/view/cbi/firewall_zoneforwards.htm


Hi @lizh, thank you for the reponse.
In the end I

  1. cloned the openwrt source from
  2. cherrypicked commit b2ef49741602b306b910c77288edda8dc059031f from into the official openwrt source
  3. deleted the led patches, because they don’t apply anymore, and
  4. copiled an openwrt version from that for the brume

I flashed it and it works nicely.
I’m ok for now. I hope the mv1000 will have an official openwrt version soon so I don’t need to compile from source by myself.



and especially for those who don’t know how to compile it themselves :wink:

1 Like

@Simon - can you share your image, or give more detailed instructions about how others can do this? I want to do this as well.