GL-SFT1200 Opal 4.x testing

I loaded the 4.1.1 beta1 firmware on my Opal yesterday and set it up just as my Slate AX, very simple setup, just changed wireless SSID’s/PSK, LAN subnet and setup WireGuard. However, when trying to connect WG on the Opal it never completes fully and just logs this in cycle until I toggle to disconnect WG again.

Thu Dec 1 14:37:37 2022 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Thu Dec 1 14:39:04 2022 daemon.notice netifd: Interface ‘wgclient’ is now down
Thu Dec 1 14:39:19 2022 daemon.notice netifd: Interface ‘wgclient’ is setting up now
Thu Dec 1 14:40:21 2022 daemon.notice netifd: Interface ‘wgclient’ is now down

I do however get a ping response through from the server side to the client side (Opal) when it is in this state. Anyone with any idea? I can also reach the Opal web GUI from server side.

I also faced the same issue, WG client stays in Connecting state.
Also, on stopping the WG Client, internet doesn’t work until the router is restarted.

Sorry this firmware has big problems. Will fix asap!

@alzhao Sorry for the offtopic, will GL-SFT1200 get upgraded to recent Openwrt versions from 18.X in future?

Sorry. Not be able to upgrade openwrt version for this model.

Any idea when we can see and updated beta for this device?

For version 4.2 (latest snapshot on 12/01/2023), I am not able to use the repeater mode to connect to any wifi. Here are some screenshots:

@alzhao, I just tested the latest 4.2 (Jan 14) snapshot now, still unable to connect Repeater mode. That worked with the 4.1.1 beta1, but none of the 4.2 snapshots tested works for me. I get the same issue as @Maro has documented many times. Any chance this issue can be looked into?

1 Like

I confirm. Tried the jan 14 snapshot build and still same issue. The router cant connect to any wifi uaing repeater mode.
Any possibility this can be looked into?

I too am having this issue (from the WG split-tunnel post)

I’ve only just realised there was this Beta forum, @Maro how do you have access to V4.2 as it’s not out on the Download Center page?.

Its not a beta version. It is a snapshot version.
You can access it from this link

I have again tested the latest snapshop 4.2 (Jan 17) and still the same Repeater mode problem persists. Unable to connect to any wifi in repeater mode.

Using V4.2 I find that WG VPN is broken when using a split-tunnel setup of
AllowedIPs =

Pinging the range works as expected, but pinging does not, nor using a browser.

Can provide more details if needed.

Pls wait for bug fix of Opal firmware.

@alzhao Understood, but how can we know when it makes sense to start testing the snapshots?

It is expected that the repeater problem of SFT1200 will be fixed next week, and we will inform you.


@Dipin, any progress during this week?

Hi,The developer is back in the office today to deal with this issue, I haven’t been given a timetable yet. will let you know as soon as it’s resolved.

1 Like

Hi,Please download the latest snapshot(2023-01-29) to verify the repeater issue with the SFT1200.GL.iNet download center

Hi, I just tested and can confirm that the repeater now successfully can connect to upstream Wi-Fi. Will recreate my setup on this unit to see if my WG issues also now are working or not. Thanks!

Edit: I did a full reset of my setup and then when trying to reconnect again to the upstream Wi-Fi, the UI will not accept my PSK. Field border turns read. This seems to be some scripting behind the field not liking that I paste the value into the field.

Edit2: I managed to get everything for my use case working again, but the UI is kind of unusable when trying to paste into various fields. This should really be solved.