GL-SFT1200 Wireguard Connecting to GL-MT6000 DDNS -> DDNS Trouble

Hi everyone,
I have a GL-MT6000 with a WG server.
Using the IP address in the endpoint is a nice quick connection.
I have enabled the DDNS feature and tried a couple of configuration files using the routers unique DDNS Host Name [http://xxxxxxx.glddns.com].
One config file was added to my travel router (GL-SFT1200) and one to my Linux Machine.

When the VPN is turned on in the GL-SFT1200 the VPN tunnel might connect. Sometimes I have to turn it of and on a few times before it will actually go.

On my Linux machine, it never seems to connect unless I change it back to the IP address in the endpoint rather than the Routers DDNS Host Name.

When I do a DDNS lookup (ie: https://mxtoolbox.com/DNSLookup.aspx), the Routers IP address appear correct - (I have had DDNS enable for several days now).

Does anyone have any suggestions as to what settings I could use to help the client connect as quick with the Servers DDNS Host Name as it does when I use the IP address?

Here are a couple posts about trouble with GL.iNet DDNS:
https://forum.gl-inet.com/t/glddns-com-not-resolving/37743/10
https://forum.gl-inet.com/t/ddns-failing-mt6000/39117

1 Like

DNS service has been malfunctioning for over three weeks according to GL. They are experiencing DDoS attack and hopefully they are working on something more reliable!

While we should expect better from gl-inet, I have never had any trouble with paid services like dyndns.org