Even the GL-750S is a better choice then the mango.

You would be better off getting the GL-MT1300, & install EasyTetherPro on your S7. Your gonna have to install the driver on the router, then follow the installation instructions. Once I did this it works like a charm every time.

These instructions also work on the GL-750S Router, which is better then the GL-750. Once you follow these instructions, you’ll be able to tether from your S7 without a problem without running down you data. If you hook your S7 up directly to the router without using EasyTether you will run down your data

It took me some time to figure out exactly how to do the command prompts properly, but in the end it worked perfectly. It’s flawless.

When you got to youtube, no one really has a clear straight foward video of how to do this, but believe me, it does work. You’ll get 2.4 GHz & 5 GHz at the same time, you’ll also be able to plug it directly into the ethernet plug running off of the 4G network from your cell phone, with no major data loss.

I got another GL-SFT 1200 today. This one works fine. Jus hard to believe easytether doesnt have a driver for this unit. So out of all the drivers they have, not one driver is compatible with this unit??? I’m really confused about this

The drivers is here Download EasyTether drivers - EasyTether for Mac OS X, Windows, Ubuntu, Fedora and game consoles

Managed by mobile-stream team.

I sent them an email asking if they can compile but no reply yet. Maybe you can ask as well.

Ok, I knew how to get to the easytether drivers, jus couldnt believe that none of the drivers are compatible for this unit. Theres so many. Im going to reach out to them as well right now.

I also jus sent a email to them. Hopefully they will do something about it.

I still havent got an answer back about that driver. Do they have an open source where we can configure it on our own? Like Twrp has?

I tried this but is not working for me I have a Oneplus 6. also tried in Mango about a year ago and no luck

Did you enable developer options & turn on USB debugging

Make sure the wifi if turned off on the phone before you hit enable.

Yes Developer options enabled and usb debugging on and wifi off and no go for me.

They didn’t reply to me as well. I don’t see the sourcecode anywhere

I wonder why? This shouldnt be so hard for them to do on this unit. It would be nice if there was a tool that we could use to make the correct driver on our own. I mean, if EasyTether is making the drivers for each unit, then there must be a tool.

I wonder if its possible to build your own firmware for the unit so this way you can use a driver that already exists. Sounds like alot of work. Maybe Easytether is taking their time because the unit is still new.

I think they are not active now.