GL-X3000 can't connect to SIM - wrong pin error?

Hey there,

i bought a sweet Spitz AX 1 month ago, tried it with a 5G SIM card, worked fine, then it had to wait in the closet until now.
Forgot the password i set, resetted router, tried same settings and i can’t connect to internet anymore. I get the message "SIM card has been locked, please input the PIN code to unlock it. " BUT the PIN i enter is correct, i doublechecked it with a smartphone.

My provider (o2 Germany) wants me to use the APN “internet” and Authentication “PAP”. I tried this and several other combinations of blank fields and other input, trying and researching now for many hours without success.

Also updated to the latest beta build (openwrt-x3000-4.0-release50402-0908-1694145767), no success…

I am hoping to get any hint or advice on how to get it running, help much appreciated <3

First,you disable ‘Cellular’ connection.

Then we check if it can be unlocked manually:

1,Check the current sim card status:

2,unlock sim with Pin code:
AT+CPIN=“xxxx” //Here ‘xxxx’ stands for pin code

3,Check the current sim card status again:

Have you read through this thread?

Yes,Firmware version 3.0 has a bug:
Once pincode is entered incorrectly,it will keep dialing with the wrong pincode by default resulting in more than the number of validations.This makes the sim card unusable.

Firmware version 4.0 temporarily fixed this mechanism: Each manual dial-up triggers pincode authentication only once.

this works, but how can i enter PIN automatically after each Reboot?

same here, how to unlock automatic?