GL-X3000 - Cellular connection issue

Hello all,

I have the retail unit with stock firmware 4.3.0, after inserted the 5G sim card, the system will get online for around 10 mins, then dropped to 3G network + dropped the connection and unable to connect to the internet until reboot the device (or reconnect the cellular connection).

After updated to 4.3.1, there are some improvement, the 5G will connect for awhile and then it will dropped to 3G network, but this time it will stay online.
However, the 3G connection will never go back to 5G, and all the connection will be like 5G until I reboot the system (disconnect and reconnect with manual will not fix 3G to 5G).

Seems like the modem do not play well with the system.
Will there be another firmware to fix this issue ASAP? This is a good device, but it seems to be bugged by the firmware.

Thank you.

1 Like

Download the latest beta firmware.
Use the auto connect not the manual.
Make sure the 5G signal in your location is good.

I have the same modem and it stays connected all time to my 5G provider. I am using latest beta firmware.

Hello SpitzAX3000,

Thank you so much for your suggestion, however, we have paid carrier for public ip service, so we are required to use manual APN.

With the latest beta firmware, the same thing happened, the 5G will last little bit longer, about 30 mins, after that, it will drop to 3G, the internet connection will remain in 3G speed and never go back to 4G/5G.
This is very frustrated since my other Huawei CPE PRO 5 will not have such issue at all, it will always connect in 5G with much worth 5G signal spot.

Lock the band and try again - by using manual connection you can lock to specific bands so that it won’t downgrade to 3G.

For locking band, I did it with previous firmware but not the beta one yet, I locked it with LTE band 3 and NR5G band 78, but it will eventually drop back to WCDMA.
I also tried just lock NR5G band 78, but it will not able to connect to the APN, seems it required to use LTE band 3 as well.

I am thinking if there is setting to disable WCDMA, I have tried look into Luci, but with no success.

Thank you.

Correct as the current 5G technology is built upon LTE.

There is! Check my other posts where I linked the AT manual. In that manual you will find the AT commands to do whatever you want on the modem such as locking bands, disabling wcdma …etc

I see, will you please share the AT manual link again? Since I am not able to locate it.

Thank you.

Click on my username and find my posts

Here it is

1 Like

Thank you very much, I will look into it and check it out later. Will let you know the result.

Hello again SpitzAX3000,

After 3 days of testing, I can confirmed that the AT command is working perfectly to maintain the 5G connection, which helps a lot, thank you so much.

And I still have few questions, can you help to look into it as well?

  1. After forcing the AT command to use 5G network, but once we have made changes to the APN, it will reset the mode_pref back to AUTO again, is this normal?
  2. If my network was in 3G, after switched to force to use 5G network with AT command, the connection will fail (cannot jump back to 5G itself) until I reset the modem or device.
  3. I am not sure if this is carrier or modem problem, I realize that the SIM card connection will drop randomly for few seconds in every 30-60 mins (the router do not move and stay in the same position), since I have remote device connected to it, so I need to manually reconnect the remote device again after the connection drop. Do you know if there is the way to force the modem not to disconnect randomly?
  4. Related to question 3, today, i have encountered this problem twice, the connection will not able to reestablish after the disconnection, this device will suddenly show SIM card is not registered, and I will need to reboot the modem or device to make it work again, do you have any thoughts about this?

Thank you so much for your help again.

By looking at my logs, I can see the same behaviors:

By digging deeper, it seems that these AT commands are hard-coded in the script /lib/functions/

# grep -rn 'QNWPREFCFG'  /lib
/lib/functions/            eval gl_modem -B $bus AT \'AT+QNWPREFCFG=\"lte_band\",$bands\'
/lib/functions/            eval gl_modem -B $bus AT \'AT+QNWPREFCFG=\"nr5g_band\",$bands\'
/lib/functions/            eval gl_modem -B $bus AT \'AT+QNWPREFCFG=\"nsa_nr5g_band\",$bands\'
/lib/functions/        eval gl_modem -B $bus AT \'AT+QNWPREFCFG=\"mode_pref\",AUTO\'
/lib/functions/        eval gl_modem -B $bus AT \'AT+QNWPREFCFG=\"nr5g_disable_mode\",0\'

So if you need to make it persistent, you need to modify this script by hand.

Alternatively (I did not test it though), try to use the Manual Setup and save a new profile after entering the new APN and choose your preferred bands:

I did not get that.

Yes, this is known issue and people all over the forum talking about it. It is said that it has been fixed in the latest beta release: GL.iNet download center

Try soft modem reboot instead of rebooting the device.

Well noted.

I have already limited the band in APN instead of AT command.

I am now testing the latest beta firmware, will let you know how it goes.
However, I have found out that the soft modem reset is gone in the latest beta, only AT command part left in the modem management.

GL engineers can you please comment on why the soft reboot has been removed ?

I will be testing it this weekend too! Please share your feed back. Thanks.

Hello again SpitzAX3000,

I have changed from beta to stable firmware again with previous settings.
The end result is not as good as expected.

With AT command, I can maintain 5G/4G connection, however, I have encountered several disconnections each day, the system will normally disconnected for 10 - 20 mins each time.
With my layman idea, I was thinking if it is related to band filter (open for 3 LTE, and 78 5G) in the APN setting, so I have removed band filter.
However, the result is getting worse, more disconnections, still looking forward to another new firmware which can maintain stable connections.

Which carrier is your card from? csl?


Hello Lizh,

it is correct, CSL with lte.public APN.

Thank you.

CSL needs to lock in the LTE band.

And it doesn’t actually support 5G, just 4G+.


I see, so which band should I lock?

And my plan was 5G plan, so it is 5G?

thank you.