GL-X3000 constant reboot after firmware update

It does boot but then goes into an infinite re-boot loop. The only version of the firmware which doesn’t have this problem is 4.3.0. All others will cause the boot loop to happen again.

This is the full chain of events as they occurred for me.

  • Initially I was on router firmware version 4.4.8 and modem version RM520NGLAAR01A07M4G_01.201.01.201

  • I could not connect to 5G with this configuration and I read on a post somewhere to change the modem config from PCIE to USB, which I did using an AT command - AT+QCFG=“data_interface”,0,0

  • This started the problem for me - the router went into a continuous boot loop so I couldn’t even revert to PCIE using AT

  • Resetting the router did not make any difference.

  • I re-flashed the firmware (still to 4.4.8) using UBoot. That made no difference - still continuous re-boot

  • I found this forum post and so re-flashed down to 4.3.0. That worked - router no longer rebooting. I tried going back to 4.4.8, boot problem back again.

  • I went back down to 4.3.0 and also reset the modem back to PCIE using AT+QCFG=“data_interface”,1,0

  • I then tried to go back to 4.4.8, still doesn’t work as had the same reboot problem

  • I upgraded to modem firmware to RM520NGLAAR03A03M4G_01.201.01.201 and then tried upgrading the router firmware again to 4.4.8. Same problem - continuous reboot.

So now I am on version 4.3.0 of the router firmware and version RM520NGLAAR03A03M4G_01.201.01.201 of the modem firmware and the router is stable, but obviously I don’t have any of the newer features and bug fixes that have been released since version 4.3.0.

Hope that’s clear and gives GL-iNet something to work from.

Can you go in the background and type this command? Press tab

Take a look AT the result of this AT instruction

Screenshot 2024-05-15 at 09.47.24

AT+QCFG=“pcie/mode” - ERROR
AT+QCFG=“data_interface” - ERROR
AT+QCFG=“usbnet” - ERROR

Double quotation marks please use English version
Don’t copy mine

Sorry my bad:

+QCFG: “pcie/mode”,0

+QCFG: “data_interface”,0,0

+QCFG: “usbnet”,0


please setting pcie mode


then check

ls /dev/mhi_*

I went through a similar situation and the following fixed it -


I set the interface to 1,0 and rebooted.

The /dev/mhi_* files did then appear, however, the modem would no longer connect to my cellular network. It was stable and didn’t reboot, but no Internet connection. I am with Smarty in the UK (Three’s network). The chi* files that appeared were:
/dev/mhi_BHI, /dev/mhi_DUN, /dev/mhi_QMI0, /dev/mhi_DIAG, /dev/mhi_LOOPBACK.

I reset the interface back to 0,0 and rebooted, and I have connection again, but the chi files have been removed again.

sorry, mhi* files, not chi* (auto-correct nonsense).

Thanks Cayman. It seems my modem is already set to most of these values (with the exception of data_interface as per my message above). I don’t know how to check the current value of QMAPWAC or CFUN.

The device cannot dial up Internet access?
Check the apn

The APN is fine. I don’t have to change anything except the data_interface setting and it works again.

I’ll try again in a while just to exclude there being a coincidental problem on the cellular network side at the same time as when I made the change before.

I tried it again and have the same issue. The router/modem remain in a "Connecting..." state but never actually connect. This is with data_interface set to 1,0. I did get "Cells Info" populated with valid RSRP/RSSI numbers etc., but no full connection, even after 15 mins of negotiation.

Resetting data_interface to 0,0 I got connection again within 2 minutes of negotiation.

Can I see the dial-up configuration you use with data_interface set to 1,0

You mean the APN settings? I've put them below but let me know if you mean something else.

Protocol = QMI
Port = /dev/cdc-wdm0
PIN = NULL (left blank)
TTL = NULL (left blank)
Authentication = NONE

I just had thought that maybe resetting data_interface messes with the APN settings, so I just tried it again. I set data_interface back to 1,0, rebooted, and again it didn't connect.

This time I checked the APN settings and there were completely different values in there (I'm afraid I didn't record these but they were completely different to what I posted above).

I hit the 'Abort' button, and then 'Auto Setup' to see what it would so, and after a few seconds, it connected!

So my current configuration is this:
Router Firmware: 4.3.0
Moden Firmware: RM520NGLAAR03A03M4G_01.201.01.201
Protocol: QCM
Port: /dev/mhi_QMI0
PIN = NULL (left blank)
TTL = NULL (left blank)
Authentication = NONE

Are we at a point where I can try to upgrade my router firmware again or is there more to do?

You can try to upgrade the firmware

Assuming you are using, AT+QCFG="data_interface",1,0 (0,0 for usb,usb)(1,0 for pcie)
To set APN and get a connection , i did the following (I am in the USA and use Tmobile service, dynamic IP address)
AT+CGDCONT=1,"IPV4V6","" (replace "" with "")
AT+QMAP="MPDN_rule",0 (Turn off IPPT mode to bridge its WWAN to its LAN interfaces)
AT+QMAP="DHCPV4DNS","enable" (disable the onboard DNS proxy; recommended for IPPT; otherwise you may get constant connect followed by disconnect)
AT+QMAPWAC=0 (0=usb3 port,1=eth port)(set dial, req IP)

Then reboot
After reboot, i use manual option to connect with the APN settings

Thank you @ywp and @caymann. I have now managed to update the firmware to the latest version. After the reboot the router did not connect again, so I once again had to click 'Abort', then 'Auto Setup'. Then it connected fine. So to confirm, my current settings are as follows:

Router Firmware: 4.4.8
Moden Firmware: RM520NGLAAR03A03M4G_01.201.01.201
Protocol: QCM
Port: /dev/mhi_QMI0
PIN = NULL (left blank)
TTL = NULL (left blank)
Authentication = NONE

As a reminder @ywp, what started this whole saga was not being able to get a 5G connection on the Three network in the UK (when on firmwares 4.4.8 / RM520NGLAAR01A07M4G_01.201.01.201) and changing the data_interface setting from PCIE to USB in order to fix that issue. That got me into the infinite re-boot loop which meant I couldn't change the setting back to PCIE and the only way to stop it was to UBoot to firmware 4.3.0 etc etc.

Perhaps GL-iNet can fix this issue from occurring in the next firmware release - I have seen in other forums people having the same issue and ultimately returning the router for a refund - which is a shame as I think it's has the potential to be an excellent device. Perhaps also providing an easy path to upgrade the modem firmware through the router GUI would be helpful. (Incidentally I do not know if my 5G connection now is because I upgraded the modem firmware form stock or for another reason - but it works now!).

Again, thank you @ywp and @caymann for spending your time trying to help me fix this.

Best regards.