GL-X3000 iPhone tethering up but no Internet connection

tethering goes up, but without Internet :cry:

How did you find out that there is no Internet?

cannot navigate to any site!

It could be a dns issue. SSH into the box and ping google.com.

And ping 9.9.9.9 as well, since pinging a DNS name doesn’t make sense if DNS fails.

ok, I did set up this test bed:

  • my pc connected with eth to gl-x3000
  • only tethering interface up and running

this happens:

  • can ping google.com and amazon.it from ssh
  • can ping 9.9.9.9 from ssh
  • cannot ping/navigate from my pc ??? BUT ADDRESS IS RESOLVED !!!
    (I tryed to ping my public nas and address is the same both on ssh and my pc)

this drive me crazy :flushed:

Set your dns correctly in the pc.

DNS Servers . . . . . . . . . . . : 192.168.8.1
and address is resolved by ping !!! (see my updated post before this).

same problem with an Android pixel 4a:
ping name resolved, but no answer.

That’s nearly impossible.This would mean that HTTP or HTTPS is actively blocked here.
Please run nslookup google.com 9.9.9.9 from your PC and send the complete output?

C:\Users\mz>nslookup google.com 9.9.9.9
DNS request timed out.
timeout was 2 seconds.
Server: UnKnown
Address: 9.9.9.9

DNS request timed out.
timeout was 2 seconds.
DNS request timed out.
timeout was 2 seconds.

what is 9.9.9.9 ???

C:\Users\mz>nslookup google.com
Server: console.gl-inet.com
Address: 192.168.8.1

Non-authoritative answer:
Name: google.com
Addresses: 2a00:1450:4002:416::200e
142.251.209.14

more info:

ok it’s United States Berkeley Quad9

C:\Users\mz>ping 9.9.9.9

Pinging 9.9.9.9 with 32 bytes of data:
Request timed out.
Request timed out.

It seems like the traffic gets not routed properly.
The bigger question now: Why is it like this - that’s something I can’t answer right now.

What’s the output of those commands on your PC?

ipconfig /all
route print

note: my ip is IPv4 Address. . . . . . . . . . . : 192.168.8.239
(is there a way to send text files?)


.

Looks good so far.

image

This one confused me, but it should not hurt anyone.

these are my current (default) Zones:

that’s my hp laser into the fritz box subnet, to which I connect via wifi only after tethering test

Something appears to be odd to me. Can you quickly draw a sketch of your network?
draw.io will help. Please include IP addresses.

very nice tool, never stop learning :hugs: