GL-X3000 Repeater Connection Problem

My router is Model GL-X3000 connected to the internet viaT-Mobile in sim slot 2 or a Verizon sim card in sim slot 1. Firmware is Version 4.0; Type 0405 release 1. DNS is from cellular and DHCP, no Static I.P. The GL-X3000 connects to the internet readily via either sim card or by tethering from my cell phone. In repeater mode, it will connect to my current Wifi network; which is provided by an older Pepwave CAT 18 celluler router. It will also connect in repeater mode to my friends unsecure Wifi guest network. The problem I am having is with connecting to the Wifi network in the RV Park where we are residing for the winter. I have tried cloning the MAC address of my current Pepwave network that will connect to the RV Park Wifi, but it doesn’t help. When attempting to connect I get a BSSID, but nothing else. I am new to this and really am lost as to how to correct the problem. Any help would be greatly appreciated.

Can anyone from GL.inet staff please give me some direction or help with this. My GL.inet AR750S connects to this Wifi in repeater mode, so why doesn’t the GL-X3000? Thanks

Could you please post a screenshot of the Wi-Fi scan (the screen where you see to which Wi-Fi you can connect)

Here’s the screenshot. The TWRVRESORT is the one I am unable to connect to.

Ok, let us do some basic troubleshooting to get some information:

  1. Reboot the router (it’s important because it will flush the logs)
  2. Try to connect to this camp Wi-Fi (and it will fail, I guess)
  3. Get the logs and upload the tar file here

logread.tar (199 KB)
Here’s the log file

@hansome Sorry for pinging you, but maybe you or some other staff member could have a look into this?

Has there been any report back on my logs? Do you know what the issue is ?

Nah, unfortunately not.

I would assume that the problem is that the BSSID does not fit to the SSID - which can happen with 802.11r (roaming). Did you lock the BSSID?

I tried again both lock and unlocked - no difference.

The problem may be caused by a bug that happens on X3000 and MT3000 in repeater mode. In some network the router fails to get IP address. We are still investigating this issue. Sorry for that.

If you want to have another try, just remove the saved SSID and try again.

1 Like

I installed the latest firmware received today (4.0406release1). I rebooted after removing the saved SSID (TWRVRESORT) and rescanned. I entered the required password and tried to connect to the Wifi SSID, TWRVRESORT; and the connection failed once again. Now, I am not even getting a BSSID, just a yellow box stating it failed to connect. Have there been many reports of this occuring, and if so; how long before we can expect a fix. This is really affecting our internet needs. Thank you for any help and updates to enable this function

We will make a new firmware with open source wifi driver so that it is more compatible in repeater mode.