GL-X750 drops AT&T connection

Ok… I’ve got a GL-X750. Put in AT&T SIM. To be clear- I’m fairly technical, but not when it comes to this device…

So, I ‘tooled around’ with the settings and got it to connect.
This means that:

  1. I changed the IMEI to match the IMEI registered to the SIM.
    AT +EGMR=1,7,“my-imei-number-here”

  2. This is a Data-only plan, so I read I need to go in and set the APN to broadband.
    I do this by clicking on Manual.

Then I can connect.

…And the connection stays up for a while and drops.

I tried the things in this post:
AT&T Network Fix Solution

Where do I begin to troubleshoot this? What more info should I share?

I’ve been looking in the logs, online… Am at a loss.

Thanks,
-Dan

Here is what I did factory reset “under more settings - revert firmware” then I gave the at commands listed then rebooted and it has worked since.

Can you try changing ttl

Change TTL.

  • How?
  • Why and to what value for ATT?
  • Where can you see this in the logs/see this makes a difference?

More:
I don’t know how to change the TTL. I could figure out how to do it, but that’s a link to a command without context for me. I’ve not had to SSH in yet. I run a command? Shouldn’t I edit a file to change a config? I find if I click on the wrong thing (like Auto to connect) it undoes my AT commands and config changes.

If you’re telling me to change TTL, what should I change it to? And why? Can I see in the logs what you think is happening and how this fixes it?

I appreciate advice, but I’ve been “trying stuff” for a week and it’s really not the correct way to diagnose and fix a problem.

I’ve read a few threads… It looks like people are changing TTL because they are having trouble with tethered phones, which is not my setup. And their problem is speeds, which isn’t my problem… ?

More Settings -> Advanced -> Network -> Firewall -> Custom Rules

Post this at the bottom and restart the router:

#ipv6ttlfix
ip6tables -t mangle -I POSTROUTING -o wwan0 -j HL --hl-set 65
ip6tables -t mangle -I PREROUTING -i wwan0 -j HL --hl-set 65
#startTTL
iptables -t mangle -I POSTROUTING -o wwan0 -j TTL --ttl-set 65
iptables -t mangle -I PREROUTING -i wwan0 -j TTL --ttl-set 65
#endTTL

2 Likes

@RichP
Thanks for the advice.

I’ve read up and now understand that carriers use the TTL value to determine if there are additional devices ‘behind’ the device connecting to them, and that command will adjust the TTL so that everything looks like it originates at the x750.
Can you point me to where you found that this is the cause of the problem? I’m trying to find the resource that links my problem to TTL values.

I also tried a NETGEAR lb1120 and have the same symptoms… after a while, able to ping, but not able to get any traffic higher up the stack… So it is something happening upstream that’s not just the device.

@DanDan I think you saw the other thread where some people are having “proxy” issues on Port 80/443 traffic. The only solution I have seen, that you can implement outside of ATT fixing it, is running a VPN.

I am testing Mullvad, Windscrbe and StrongVPN via Wireguard protocol now.

I am leaning towards Windscribe because they have Ad Blocking and a few other controls, but need to do more back-to-back speed tests early in the morning (off-peak)

1 Like

You can do adblocking using Adguard on your GL router, no need for external service for that.

@Johnex is that a setting in the control panel I have been missing on the X750?

If you are on the latest firmware from here:

https://dl.gl-inet.com/firmware/x750/testing/

It should be in the Applications menu.

If not, could you request a build in this thread please?

@johnex “X750 is not powerful enough to run adguard.”

Ah that sucks. We then in your case you will need a service such as NextDNS :confused: