[GL-XE300] Cannot send SMS

Dear All,

I'm facing a strange situation in my admin page as my GL-XE300 can't send SMS from the Web portal.
Anyway, it receives SMS very fine except the delay of something like 1 / 2 minute(s).

Any advice ?


This could be an issue with the modem firmware. Some older ones do have issues.
Can you pls post the screenshot of the modem status page?

What do you mean by "Modem status page" ?

I can't seem to find the modem firmware version anywhere in the Web portal or even in Luci :frowning:

I sent the following AT command : AT+CGMR ... and got this result :

On the left side of web Admin Panel -> INTERNET, Cellular sector.

Is that what you're looking for ? >>> EP06ELAR03A08M4G

@alzhao Needs to take a look here.

Which version of your firmware is it?
I remember the latest firmware fixed this problem, can you try it?



I'm already on this firmware 4.3.17 (2024-06-20) and previously I was on the previous one 4.3.16 (2024-02-27).
The EP06-E firmware I have, as said previously EP06ELAR03A08M4G and someone from support team on Quectel forums sent me the latest version as per today which is : EP06ELAR03A20M4G

Yet don't know how I am supposed to flash this firmware as it is a small Linux system with a non-x86 architecture.+ very small storage space.

If I have to go on the firmware update path, I will have to open my GL-XE300C6 and take the mini-pcie modem to put it on a USB-to-MiniPCIe converter.
Yet I prefer to wait for the feedback from someone here in order to be 100% sure I will not break anything as it seems that the firmware version downgrades are not that easy.

try this?

Have you tried @ywp 's suggestions?

Just upgraded modem from :


Didn't restarted the GE-XE300C6 yet after the upgrade but for now, although the 3G/4G LED is on and blinking from time to time, modem is not answering to command "gl_modem AT AT+QGMR".

Should I POWER OFF the whole module and POWER it back ON again in order to see or am I running into a problem as my version was EP06ELAR03... and the one I upgraded it to is EP06ELAR04 ???


Well ... I ended POWER cycling the device and things are back to normal.

Anyway, I still can't see anything more in the SMS send view :thinking:


What do these AT instructions return?


Here are the results :
NB : I changed the last query in order to avoid overriding the existing values :

AT+CREG? >>> +CREG: 0,1

AT+CEREG? >>> +CEREG: 0,1


AT+CPMS? >>> +CPMS: "ME",0,255,"ME",0,255,"ME",0,255

There's a bug

opkg list-installed|grep modem

Because I don't know your firmware version
Can you check the commit of the current modem?
I will compile an ipk and send it to you later

Upgraded modem yesterday to this version : EP06ELAR04A22M4G

AT+C5GREG? >>> ERROR is a normal situation as this is not a 5G modem :slight_smile:

"opkg list-installed|grep modem" command output :
gl-sdk4-modem - git-2024.051.12748-ec06776-1
gl-sdk4-ui-modemmanage - git-2024.066.15334-b8639af-1


I know,There's something wrong with the code handling
thank you

What do you mean ? :slight_smile:

gl-sdk4-modem_git-2024.051.12748-ec06776-1_mips_24kc.tar (236 KB)
Use winscp to upload the file to the /tmp directory

opkg --force-reinstall install /tmp/gl-sdk4-modem_git-2024.051.12748-ec06776-1_mips_24kc.ipk

Yet, WinSCP refuses to connect because of this error message.

I had to use a USB stick in order to get the file in /tmp folder.
After running the command "opkg --force-reinstall install /tmp/gl-sdk4-modem_git-2024.051.12748-ec06776-1_mips_24kc.ipk"
I got these results :
Removing package gl-sdk4-modem from root...
Updating database.
Database update completed.
Installing gl-sdk4-modem (git-2024.051.12748-ec06776-1) to root...
Configuring gl-sdk4-modem.
Updating database.
Database update completed.

Checked WebUI >>> still the same

Rebooted the device then went to Internet / SMS > Send >>> still the same