GL-XE300 (Puli) - Device works slowly

Good morning,

I recently connected a GL-XE300 (Puli) device with a SIM card in Poland - T-Mobile network. The maximum download speed I can get is around 23 Mbps. When using another device, the speed goes above 100 Mbps. I would appreciate your help in setting up the router to achieve at least 50-70 Mbps…

xe300 uses cat6 module. What modules do you use for your other devices?

Thank you for your response!

Until now, I had the SIM card inserted into an iPad or iPhone, and the download speed on them was over 100 Mbps.

I bought this device GL-XE300 to have a more convenient way of using the internet.

I don’t use any other tools or modules, only this device.

It says on this device that the speed is up to 300 Mb / s, and I barely have 20 Mb / s. So what’s it like in the end?

Is your iphone using 5G?

GL-XE300 uses 4G LTE CAT6, theoretical speed is 300Mb/s, but the actual speed depends on the local base station network.

I am using LTE (4G) on my iPhone or iPad and have over 100Mbps on this technology.

I understand that it depends on the base station, but since I have over 100Mbps on an iPhone or iPad, then on this device for which I spent over 100 euros, I should have at least the same :slight_smile:

Can anyone help me configure the device to work as it should?


Can you confirm that you changed the IMEI to match your phone’s IMEI and that you changed the TTL too?


I didn’t change anything. Settings:

I understand that I have to set the GL-XE300 the same as the iPhone?

What values should I enter in these fields?

Your iPhone and iPad most likely have better cellular modems. This device (Puli) has only Cat 6 modem. iPhones newer than 6s are likely to be faster than Puli, because they support higher LTE Cat category or even 5G. I’d suggest to return Puli and get something faster.

Example iPhone LTE categories:
Faster cellular devices:

@lecmipahu Great, thanks for the specific answer.

In that case, why does it say in the offer that the modem supports up to 300 Mb / s, if in fact it does not?
The second issue - since you write that I should buy the devices you mentioned, how sure am I that it will not be the case again that the device description says that it supports up to 10,000 Mb / s, and it will work again at 20 Mb / s :laughing:

That’s just a specification and can be achieved only in a laboratory. In the real world you have many other devices around you that compete for the same radio spectrum from your nearby cell tower(s). Also mobile operators usually don’t even have all radio resources that are needed to deliver that theoretical speed. That’s the case in Poland and many other countries where you have many major networks working within a limited radio spectrum.

The same happens with WiFi. The speed on the box is maximum theoretical, but you’ll never get gigabit WiFi (AC/AX) if there’s any wall between you and your access point. Plus different devices support different number of streams, coding, etc. Not to mention other nearby networks that might be in use at the same time and slow down your network.

All in all you can order stuff these days, test it for 14 days and return if it turns out not to work for you.

Something must be wrong here.

1.Why then such devices, if you can get a faster internet connection from an ordinary phone?
2. So I understand, it is not possible to unlock a faster connection from this device and you have to pay as much as 400 euros to achieve the speed that the phone also gives?
3. And how does it relate to much cheaper devices through which the internet works on a sim card and the speed is around 100 Mb / s?


Today I connected this device for the first time since purchase using an Ethernet cable with a laptop, thinking that since I received answers that the iPhone works better and supports higher speeds…
Unfortunately, there is no improvement with the Ethernet cable. Same. Max.~20Mbps.

I’ve already found similar topics on this forum, people had the same problem, but from what I’ve read, there’s not a single specific answer on how to solve the problem with this device blocking the internet data transfer speed.


If something doesn’t work well, then you try one thing after another until you find where the issue is

One elementary, basic check is to change the IMEI to match your phone’s IMEI and also change the TTL to 65

If you don’t know how, search on the forum on how to do it

Another thing, I don’t have iPhone but on Android there are few apps to see on which bands your phone is connected

Check to see if there are in Apps Store the following apps: ‘Netmonitor’ by parizene and ‘NetMonster’ by Michal Mrocek. If there are download them. There are very useful in order to understand the mobile carrier’s signal at your location

It all depends on device’s capabilities. As I already said, Puli is Cat 6, but any iPhone since 6s (2015?) has higher Cat so will probably provide faster connection. Modern phones aren’t ordinary in this regard. They have sophisticated modems and antenna arrays. Also they cost often more than Puli.

As far as I know advanced LTE and 5G modems are expensive. There’s also the second hand market full of slightly slower devices (lower Cat rating).

Which ones exactly?

Of course there’s a possibility that you’ve got a dud, configuration is messed and other factors. Yet the hardware capability gap is the only thing that can be inferred from the information you’re shared so far. Comparing Puli to an iPhone is like comparing apples to oranges.

Ok, thanks for the help, but should I enter it in the register of the device, e.g. MacBook, or do I enter these commands in the settings of the router panel?

Here is an example for changing the default IMEI for the Puli router:

and here an example for the TTL:

Thanks for your help, but there is nothing specific about these topics. There should be instructions on how to configure it. In the case of other routers, you insert a sim card and everything works fine, here you have to gymnastics.

I changed the IMEI address on this device to the phone’s IMEI.
I added:
ip6tables -t mangle -I POSTROUTING -j HL --hl-set 65
ip6tables -t mangle -I PREROUTING -j HL --hl-set 65

iptables -t mangle -I POSTROUTING -j TTL --ttl-set 65
iptables -t mangle -I PREROUTING -j TTL --ttl-set 65

I have turned ipv6 on and off.

It still works the same.