Global protect VPN resulting in Internet connection cutoff

Hi everyone.

I have a x2 Slate Plus router(wireguard)(server in US and client on another continent) setup on personal laptop for work. When doing normal browsing my internet connection is fine.

However after connecting to work global protect vpn i lose connectivity to the internet. Can anyone please assist with a solution to this problem?

Try change mtu in your windows.

I have changed it twice today from 1500 to 1400 and 1280 for both ethernet adpaters.Still not receiving anything.

Can you try even lower mtu?

I lowered Ethernet 1(GLRouter) to 600 form 1280 and Ethernet 2(GlobalProtect) from 1280 to 900 and it started working smoothly.

Switched off everything,reconnected and the connectivity issues came back.

Then checked mtu again only to realize GlobalProtect has restored back to the original 1400mtu so lowered it back to 900 and connecton issues continued.

Now lowered everything to 550 and connection restored.
Not sure what’s happening but your suggestions are doing somtething :+1: thank you. Where do i go from here

MTU 550 is waaaaay to low, something is odd here. Normally you would need something like 1260 - but nothing under 1000.

You should only need to lower the mtu of your computer’s Ethernet to GL router and make it persistent

It’s quite odd. The no internet problems are persisting. I have tried changing MTU again and again with no luck at establishing a solid internet connection. It sometimes connects and i can browse then if i turn off the PC/Disconnect Global protect it stops working.

Okay thank you I’ve figured and made it persistent, played around with a few MTU numbers for GL ethernet only but still getting the problems with internet connectivity once connected to Global Protect.

Guess you can use something like this to get the best MTU:

1 Like

I have done this and it’s not bringing up any optimal MTU. Instead its timing out.

The global vpn application itself should detect optimal mtu. But it didn’t