GLx 3000 spitz 5g keeps disconnecting and changing apn for no reason

Hi,
my spitz after X hours (they can be 2 or 20) disconnects from provider and never connects again unless I reboot.
I did try to contact the customer support but nothing they told me to do worked, even changing to a different power supply :face_with_raised_eyebrow:.
I updated to beta firmware, the modem firmware, forced certain bands....and so on.
What I have seen is than for some reasons the router changes the APN to a different one and disconnect. If I try to set back the right apn it does not let me do it unless I reboot.
With my old 5g Zyxel I had zero problems.

Thanks.

after successfully establishing the connection, disable Multi-WAN under the Network section for all the four modes (Interface Status Tracking Method).

If I disable multi wan I lose the backup connection I have via dsl.

Is this a known issue with this router?(Interface Status Tracking) My router reboots itself constantly throughout the day and it's driving me crazy. Many times it simply locks up and I have to power cycle it multiple times in order for it to power back on. And then when it does power on, it's looking for SIM slot 2 when I don't even have SIM 2 configured for anything. Support says that the router switching to SIM2 shouldn't happen but it does. I'm frustrated with this router and am thinking of getting something else if it can't keep a connection. I quit recommending this router and have been telling people to stay away from it for a while.

Does your APN switch to "internet"? I have a similar issue but my provider lets you limp by at less throughput with the wrong APN, you can watch it dip to a throttled 5mbps with the wrong APN.


Can you change redial_sim to sim for a try?

hello Yangweiping, you were trying to help me with a similar issue. I still cn't get my Verizon SIM to work and Verizon business is telling me that they can't help me. I even spoofed my IMEI from my Verizon Business Gateway device. I also changed the APM to "VZWINTERNET" as you had suggested and that doesn't work either even after a reboot of the router. Are you aware of any other settings that I might need to set like PIN, TTL, PIN, Authentication? Any help is greatly appreciated.

I have the Verizon SIM loaded in slot 2 as I have the T-Mobile 30-day trial card loaded in slot 1 and that one works fine. The Verizon SIM2 keeps saying that Card not registered after trying to auto-configure SIM slot 2 after a long time.

Yes, it switches to internet and lose connection. Even If I select my provider profile it says "saved" but it does not. I have to reboot the router in order to use the selected apn but than after x hours it goes back to "internet".

I always use the Manual Setup button never have to reboot. I set up profiles for fun but my APN is in the list of defaults so I tend to just manually reconnect.

The UI for SIM switching is really confusing/unintuitive and sometimes has a mind of its own. I sifted through logs today and nothing related to cellular.

Part of me thinks it’s power related or the sim slot but the few times I just arbitrarily cycle it by pulling the plug or eject the sim it’s recovered.

My environment is hotter than most and voltages do dip but again, I can’t reproduce this trying to mimic low voltage scenario or find any correlation.

1 Like

Hi,

Here discuss.

  1. Please let know what the firmware version of your X3000 and the modem is?
    Enter the AT command here to check:

  1. Please let me know if does the auto-sim enable?

SIM 1 is “Active” and auto switching is turned off.

The router disconnected again at 2AM, I had to reboot it manually this time as I had to go back inside as it was raining for it to work again.

It seemed stuck on 4G, APN settings were intact this time, manual setup did not reconnect.

@Bruce can we make the log screen persist the last reboot? I didn’t see anything before I rebooted. I have a pi on the same network if it helps, this is the device going down between 2:30 and 4:30 (it runs a test every hour).

Also I cannot embed more than one image in a post because I am a “new user”.

It's a little messy. Let me check the problem

  1. Sometimes the router will restart and then modify the apn
  2. When 1 occurs, manually setting the connection does not take effect. You must restart the device again

Anything we can help investigate in the meantime? I asked about the logs. Every log I’ve seen just has my wwan trying to connect to tether which is normal.

Another day, another power cycle induced “internet” APN selection.

It supposed to connect the cellular (modem) not tethering, may I know did you also have tethering connectivity?

Has this approach been tried?

This is a mobile rv application, I know many hotspots and if they are in range it should use those.