Help getting Zerotier to run on GL-X3000?

Getting zerotier to run on my GL-X3000 seems to be impossible…
I enable it and enter in the network id and it just says connecting. And never shows connected or trying to connect in the zerotier site dashboard.
Is this broken or am i doing something wrong?

Thanks in Advance

Have you enabled “auth” on zerotier dashboard for your X3000?

1 Like

i cant because its not showing up on their dashboard.

On the gl.inet it just stays like this in the photo saying connecting, has for two days now. Made sure the network ID was correct and tried to start a new account and reload it, turn it off and on. Nothing it just looks like this in the photos…

Hi, can you show your configuration in the /etc/config/zerotier section?

1 Like

im not sure what you mean or where to go for /etc/config/zerotier

It looks like connecting to zerotier server failed.Could you run ping and ping via ssh to make sure zerotier server is reachable in your network?

i dont know how to do that, other than im guessing thru putty somehow?

Right! Please refer to SSH to the router - GL.iNet Router Docs 2

getting a resposnce back from
but not from
however i do get one from using ping

btw i do have my mtu set as 1420 ttl 65 and this modem does appear as a Tablet,
out of curiosity upon enabeling zerotier from the gl.inet router page in openwrt, was i suppose to go open ports or do some type of firewall rules or anything other than checking the turn this on switch on enable zerotier, and enable the lan and wan? If so what other steps should have i done?

Is your device connected to the server now? You need to enable lan/wan if you want to remotely access it from other nodes of your zerotier network.

as stated, it wont connect thats the issue. yes on the x3000 from photos their checked on
phone connects to the site fine but the x30000 doest

Hi, can you please connect to the router via SSH.
Execute the command: cat /etc/config/zerotier
Show the results of the command execution.

The configuration looks normal.
Please ping these zerotier root servers:

|root-lax-01|Los Angeles||

And execute the command
zerotier-cli status
Make sure the status is online
If not, then execute the following series of commands:

service zerotier stop
service zerotier start
service zerotier enable

And check the status again
zerotier-cli status

Let’s try the following steps.

It seems that your router is unable to access data transmission via UDP port 9993 towards ZeroTier servers. Do you have other devices that access the internet through your router and are successfully connected to your ZeroTier network? If yes, then:

  1. Stop the ZeroTier service using the command I provided earlier.
  2. Edit the file /etc/config/zerotier:
config zerotier 'gl'
    option wan_nat ‘1’
    option nat '1'
    option enabled '1'
  1. Enter the command service zerotier start.
  2. You will get the response Generate secret - please wait...
  3. After that, in the UI settings, add your network again and apply the settings.
  4. Go to the console of your network at ZeroTier Central and authorize your device.

not quite sure how to do that via ssh, i tried vim /etc/config/zerotier: and vi but im guessing that was wrong or all i did was open somthing ? Im familar with using at commands via telnet but usualy was given direction, if you could be a little more specific i would greatly appreacite the help

how do i edit that file?

You can install the openssh-sftp-server package, enabling you to edit files locally on your PC. Alternatively, install the nano editor, which, in my opinion, is more user-friendly compared to vi.

im still clueless as to how to do any of that