ZeroTier not connecting to GL-XE3000 (Puli AX)

Continuing the discussion from Help getting Zerotier to run on GL-X3000?:

Hello! I’ve run into the same issue, only on the XE3000. I’m trying to follow this as best as I can, but I was curious if anyone here (Goggles0086 / RRoommaann / Fangzekun or anyone else) actually figured it out.

My situation is a little bit different as I was able to connect and authorize my XE3000 initially and had everything running smoothly. I then plugged my other router back into my computer to access my cameras still connected to the previous subnet/router to change the camera settings. I then attempted to reconnect everything to my XE3000, and that’s where we’re at for this exact same situation coming to fruition. It doesn’t populate in my Zerotier Network (however this time around I already have it populated and authorized in my ZT Network, it just won’t connect on the GL.inet webUI side). It stays constantly showing “connecting” after being correctly applied.

I’ve tried factory resetting my router (and successfully getting back into the webUI/router is running well), updating firmware, creating a new ZT Network and adding that networkID to connect to a new network, and nothing has worked to this point.

I’ve also connected the router to SSH and tried all steps and recommendations here from pinging zerotier .com and my. zerotier. com and received something…? Non stop new sequences kept populating, but it looked it did ping initially with 56 databytes?

I then ran command: cat /etc/config/zerotier and got different results than Goggles.

Any and all help would be greatly appreciated - thanks!

Could you please run the following commands and post the output?

zerotier-cli info
zerotier-cli listnetworks
zerotier-cli peers

Note that this will expose personal data - I would recommend changing the ZeroTier network ID after that or masquerade it before posting.

Apologies - I’m just not 100% sure what data within this situation could be used against me. I’d rather be over precautious then under! Let me try again.

This is all commands including /etc/config/zerotier from before:

Please try to get ZeroTier up again by first leaving the network.

zerotier-cli leave [Network ID]
zerotier-cli join [Network ID]

Then accept the request inside your ZeroTier admin panel.
Make sure to delete the old device there before.

I just left, and am about to join, however before I do so I would like to add that I have actually attempted to delete the old device first, but ZeroTier provides me with this warning pop up:

As you may be able to tell I have already deleted the Managed IP from this device while trying different things to troubleshoot the connection as well (don’t know if that matters). Even with that warning should I still delete it from my ZT Network?

Yep, delete it. It’s just a warning that you can’t rejoin with the same ID - but it should be fine.

Hmmm - nothing’s populated yet. I then took another step myself to see if it mattered, but one at a time. First the initial responses:

I then went back into my Gl.Inet webUI and noticed that I was still showing “Connecting” on the ZeroTier page, and unchecked “enable ZeroTier” - clicked apply. Then went back to SSH to try to leave/join again. This is what I got after attempting to leave:

Hm, no idea from my side so far. Need to test it with my own device - but this will need a few days.

Maybe you can try to delete the zerotier config file and try joining by cli again?

I’m all for it. Would you mind giving me a quick run on on how to execute those commands/prompts?

Also I followed the other forums step by step all the way to downloading nano to edit the file of cat /etc/config/zerotier - but, if I’m being honest, I have no clue how to properly install nano, nor edit (once installed) a command to then send back into SSH.

Here’s what those steps looked like on my second attempt after trying to ping all four locations provided by RRoommaann (successfully kind of? Again - the command never stopped populating new sequences, but did ping?)

just use rm /etc/config/zerotier to kill the whole config. Reboot after that.

1 Like

Just tried and it didn’t at least show any response haha. Did I do it right?

Yup, file deleted.

Now reboot and try the join command from above once more.


Now should I go back into the Gl.Inet WebUI to try to reconnect, or do anything else from SSH?

Ignore the GL GUI and go straight to the ZT portal and activate the new device

Do the status command after that.

Wait. You executed the command on your Mac instead of the router?

(Same guy - reached maximum amount of responses in my first 24 hours here so account #2 engaged) –

Well wouldja look at that - I did facepalm. After the reboot didn’t realize I need to log back into the router ssh root, and just did it straight through the populated command. Gimme one second to try again.

… I was just about to say “hmmm nothing populated on the ZT Network to authorized…” I WONDER WHY haha

Didn’t work. facepalm once more

I extended the permissions for your other account so you can stay with the old one. If it’s OK for you I would delete the new one then - so nobody gets confused.

Since it’s night time here I will continue to look into this issue tomorrow!

Beautiful, thank you so much!

You’ve been amazingly helpful.

Execute the following command in ssh
touch /etc/config/zerotier
uci set‘zerotier’
uci set‘0’
uci set‘0’
uci set‘0’
uci commit zerotier

Restart on the GL GUI zerotier page

zerotier-cli listnetworks