Help GL-X3000 Spitz AX Using Visible SIM

Anyone have success connecting GL-X3000 Spitz AX using Visible cellular? I’ve tried to get the GL-X3000 to connect to cellular using 2 different Visible SIMs. This GL-X3000 has the Quectel RM520N-GL modem. I’m using firmware version 4.0-release10305. I’m unable to get 2 different Visible SIMs to work in the GL-X3000. Both of the 2 SIMs have already been activated using the Visible app, on a cell phone, for about 4-5 months now. Both Visible SIMs were activated on the newly upgraded (new version) Visible plan. Both of these 2 Visible SIMs currently work successfully in an Android Samsung A54 phone and a Samsung Note 9 phone. Both of the 2 Visible SIMs currently work successfully in a Cudy P5 and MOFI 4500 router. The GL-X3000 is reporting “SIM Card Not Registered”, when trying to connect either SIM, using the Admin Panel>Cellular menu on the GL-X3000? I have tried many APN configurations with vzwinternet, vsblinternet, no TTL, no MTU, different TTL settings, different MTU settings, and no success. I have tried using the GL iNet Android phone app setup wizard with no success. I’m using a Waveform 4X4 MIMO antenna. The MIMO is of course reporting excellent signal strength in the GL-X3000 Admin Panel. So, this is not a signal strength issue. I have tried using both of the SIM cards in both SIM 1 and SIM 2 slots on the GL-X3000 with no success. So, there is seemingly something in the GL-X3000 firmware or modem that is impeding the 2 SIMs ability to successfully register when being used in the GL-X3000 modem/router? I must return the GL-X3000 by September 2nd, so this is time sensitive. I sent the same request to and but have not heard back from them yet. Any info/insight/help would be greatly appreciated!

Technical support has reviewed and responded to your email. Please view your email box.

@User97856 did the reply from technical support help you get up and running with Visible? Could you share what they recommended? Thanks!

Visible was working for me a few months ago and then stopped working. As of two weeks ago it is now working again but with caveats. Usually when I power up the router Visible will not be working. If I toggle the router to sim2 and then back to sim1 Visible will start working. I’m using Version: 4.0-release10305

@pwyngaard @doczenith1
Please upgrade firmware to 4.0-release40402 and use the verizon profile.

@yuxin.zou It appears that 4.0-release40402 is still in beta. I am leery of installing a firmware without a change log based on the issues people had with the other router models moving from the 3.x codebase to the 4.x codebase. If a detailed change log can be added to the 4.0-release40402 download page I will consider trying it.

If you upload the beta firmware to the router you can view the changelog before clicking the install button.

@Thomasinaz thanks for the tip. I still think that GL-iNet should post the change log to the firmware download page. My router is out in the camper and unplugged at the moment hence some effort involved to just see the change log vs pulling up the firmware page on my computer.

@yuxin.zou I upgraded the firmware. For me, it’s still behaving the same. Visible never reliably connects on the first try, either immediately after power on, or after switching SIM slots. Sometimes I have to “Abort” while it is trying to connect. Sometimes it connects but there is no Internet, so I have to “Disconnect” and try “Auto Setup” again. Usually during this process, the Cellular Settings I have saved under the profile (APN VZWINTERNET, TTL 65, MTU 1428) are reset to internet, null, null. At this point, it usually connects to Visible and I am connected to the internet. But then I have to manually change the TTL and MTU again, and then it usually reconnects successfully.

Can you point me to any log files I can monitor (via ssh) during this process, so I can gain some insight into what is happening during the multiple failed attempts to connect to Visible and the internet every time I power on or switch SIMs?

Once I get connected to Visible, the connection remains up and stays stable indefinitely.

@pwyngaard I’ve also saw it reset the APN to internet and then had it connect and work fine. I have my TTL settings in a firewall-start (or a similar file name) file and don’t adjust the MTU so I haven’t experienced those fields resetting.

@doczenith1 Are you also having similar problems with Visible basically never connecting on the first try? When the APN gets reset to internet, do you change it back to VZWINTERNET, or leave it alone? I change it back, at which point the modem tries to reconnect again. Sometimes it reconnects, and sometimes it doesn’t. After a few tries this morning, I was finally able to get a stable Visible connection with VZWINTERNET / 65 TTL / 1428 MTU. But in all, it probably took 10 tries.

Regarding setting the firewall rules, I’ve seen mention of that throughout this forum. Would you be able to direct me as to how and where I set this on the Spitz AX? I’m familiar with ssh and the linux-esque openwrt command line. My assumption is it is a set of iptables commands I need to issue. I’m just not sure exactly what those commands look like. Thank you.

Yes, I am having similar issues but it only seems to take me 2 or 3 tries to get it working. I can’t remember if it’s using the APN internet or VZWINTERNET when it finally connects but probably VZWINTERNET.

The reason I chose to use the firewall-start file is that when I first got my Spitz a few months ago and would enter a TTL value the value didn’t seem to stick. After leaving that screen and coming back the entry box was blank. No need to SSH into the router. You can access the location for the commands via LuCI which you get to under advanced settings in the router GUI. This is what I am using which applies the TTL setting to all interfaces.

iptables -t mangle -I POSTROUTING 1 -j TTL --ttl-set 65
iptables -t mangle -I PREROUTING 1 -j TTL --ttl-set 65
ip6tables -t mangle -I POSTROUTING 1 -j HL --hl-set 65
ip6tables -t mangle -I PREROUTING 1 -j HL --hl-set 65

There should be a dummy file already on the router. I just added these lines after pre populated and commented out lines.

P.S. Can I ask why you are changing the MTU to 1428?

Awesome, thank you @doczenith1, I appreciate it. Question about the iptables command: I often see these commands include the -i or -o command line option, along with a device name. Your commands lack these, so I assume specifying the device is not necesary?

I can’t give you a technical reason why I set the MTU to 1428. I saw it in other posts in this forum. If you search for “1428”, you’ll see several posts. It probably does not make much of a difference…

I’ll paste some verbiage below that was included in the post where I got the iptables commands from. I think it may answer your question regarding the -i or -o.

“… you need the ipv6 rules as visible is over ipv6 even if you only see ipv4 addresses. Specifying 1 instead of -o wwan0 or -i wwan0 makes it the first rule and on any interface. It seems to work better and it sticks. Add it directly on the firewall page.”

From what I could tell by looking at some other examples the -o is used for the POSTROUTING and -i is used for the PREROUTING lines before the interface. On my ASUS router that I use via a USB tethered phone I include “-o usb0” for the interface.

@yuxin.zou It seems we both have problems getting Visible to connect on the first try. In my case, the Visible SIM is in slot 2, and there is an ATT SIM in slot 1. ATT seems to always work fine. How can I debug this problem? What log files should I look at? What can I share with you to get your help resolving the issue? Thanks.

Hi pwyngaard:

You can use the beta firmware:GL.iNet download center

And use the following profile:

I am using the beta firmware, release40402, and I am using that profile, but I am still unable to ever connect to Visible successfully on the first try. It takes several tries, and in the process, as described above, the SIM settings are completely reset.

How can I debug this problem? I’m very comfortable with ssh and the command line, just don’t know where to look to see where the failure(s) are happening.

I’d like to add that it’s not just settings like APN, TTL, and MTU that are reset in the profile when going through the Disconnect / Abort / Auto Setup cycles needed to finally get Visible to connect. Any Band Masking settings are also lost.

If it is convenient for you,you could share with gl.inet_support via cloud platform.I will check it remotly.

I am having the exact same problems with unreliable connections to celluar data with my GL-X3000. In my case, the device is activated on Verizon directly, not visible.

I reverted to an earlier firmware version, which had previously worked reliably. But that actually has not helped.

Try the APN suggestions from this Reddit post, seems to have resolved problems for many people: