Help GL-X3000 Spitz AX Using Visible SIM

I totally agree! I found that when I set my PC to 65 TTL/HL in cmd and then connect to the internet through a VPN I can pull 20-60 Mbps and connect as many devices as I wish (so long as I hotspot then directly to the PC) on 4g without any issue at all. This implies to me that these gl.inet routers are messing up the packets somehow and alerting the isp to throttle data. I started looking into converting an old laptop into a hotspot to overcome this entire debacle.

That’s weird, tbh. The TTL should be not the reason for that, since the VPN will use it’s own TTL mostly.

I hotspot dozens of devices with or wo vpn, ttl 88, Gl-3000 AX on Visible

IDK, I use NordVPN and couldn’t find anywhere to adjust TTL/HL limits. I’m connected to a Verizon MiFi 8800l. Even with my IPVs set, I get throttled to 5 Mbps without my VPN. I tried the “88” trick, and my speed jumped to about 10 Mbps, but I could tell it was still throttled. I use a stock Windows 11 Thinkpad, T480s if I am not mistaken. I have Nord set to auto-start and I use quick connect to the fastest router available and that is it.

I have never had my activated visible SIM card work in a Spitz router. I know another guy that got his Visible SIM card on the same day I did and it worked in his Spitz router. I have put it in a factory reset router with the same name of my phone i activated it with and it still doesn’t work. The router reads it as a Visible SIM it sees it and knows it’s there but no connection EVER!!! No matter where I’m at. I’m a truck driver. I’m all over and Visible has never worked. I could be right next to a Verizon tower and it still won’t work is my point. All I see is the orange light in the admin settings of the router never the green light that I get from my T-Mobile SIM card. There has never been an established connection using the Visible SIM. I have tried everything TTL, MTU switching slots. Reset my router nothing works. Consider yourself lucky if it works for you. I just ordered another Spitz for my house. I do love this router and hope GLnet can get it to work for visible with a firmware update. I hope to try it in the new router at home. I don’t know why that would make a difference but I’ve tried everything else. Support has not been much help.

Unfortunately it seems that Visible does not work or at least not reliable:

For Visible, should just choose Verizon profile and it will be OK.

I used my Visible (non-plus) sim with my GL-X3000 from 2/2023 thru 1/2024 through multiple firmware versions without any issues. I’m not sure what might be causing your issues but keep looking for a solution as I’m sure one exist.

I’m also having trouble.
Just to clarify. The advice is use Verizon profile, not Visible profile. Is there anything else I need to do? e.g. copy IMEI from the phone, any other settings to change?
Right now it just sits with the spinning “connecting” icon continuously.
SIM is activated and works in a phone.

This reminded me that I did change the IMEI on the Spitz to that of a Visible compatible phone. Use AT+EGMR=1,7,“replace with your IMEI”. Always make sure to take note of your original IMEI number before changing it so that you can change it back to the original if need be. Also, this was posted to the forum by a GL-iNet employee “After you change the IMEI, you should use the following AT command to save: AT+QPRTPARA=1”

Also make sure the APN being used is VZWINTERNET.


Thanks. Sadly that still doesn’t work.
I’ve done the IMEI copy, the extra AT command and tried VZWINTERNET, as well as VZWAPP as that seems to be what it defaults to.
Hopefully some one on the GLINET team can help?

And I know the SIM is working, as I’m writing this using it tethered to the SPITZ AX :slight_smile:

Ah, just had a thought …
Tethering breaks as soon as a second device connects. I’m wondering if it’s the same issue when it’s installed in the sim socket.

Is the best way to avoid this use a VPN to avoid packet inspection?

Really? This is so strange. First time heard about this

Visible has always only allowed one hotspot device per phone. This was enforced on all phones bought from Visible. The rule was not enforced on Pixel and iPhones (and perhaps others) and you could connect multiple devices to these phones. I don’t currently have active Visible service so cannot test but I’m wondering if Visible has figured out a way to enforce the rule on other devices.

Yes, it was very weird. Since then I’ve seen it written in the Visible terms and conditions. Looks like a limit of one device via hotspot at any given time … really limits the usefulness of a hotspot plan.
This was on iPhone, so I think they’re getting very smart on packet inspection.

I agree. I noticed a number of months ago that the TTL=65 trick was no longer bypassing the 5 Mbps tethering limit. With a VPN running the tethered data was no longer throttled.

I’m fairly certain that the single tethered device limit has been around since the beginning of Visible. Being that Visible is the only provider offering unlimited tethering I can understand the 5 Mbps throttle but the single device limit doesn’t make sense. 5 Mbps is 5 Mbps regardless of the number of devices. I suspect the single tethered device limit was put there because either Visible knew that people would be bypassing the 5 Mbps throttle via TTL or they didn’t want to deal with the complaints from non-tech oriented customers complaining that the speed was too slow on their tethered devices and not understanding that speeds will be slow if you share 5 Mbps between 10 devices.

1 Like

Brand new router, Visible activated in phone moved to router, worked for hours, 4.4.2 firmware, lost power, now no longer connects?? TTL is 88, VZWINTERNET, IMEI changed to phone, tether and repeater both work great…what else to try??? great cell signal…
cell settings2

Check my thread for a possible fix to your Visible woes…I know it fixed my Verizon problems…

1 Like

Now 117 or 118 is working for ttl in tether and repeater mode. Had a past due sim from bad CC for auto payment, fixed that now above two are working great again. Will put back into router to see if cell service per router is working…

Had to set TTL and HL (IPv6) to 88. 65 doesn’t work anymore.

Also, had to change the APN from ‘internet’ to ‘VZWINTERNET’ because when on the ‘internet’ APN, downstream would be fine, but after about 60s, the upstream becomes throttled to “hotspot” speeds (e.g. 2-5 Mbps). Changing the APN to ‘VZWINTERNET’ solved the upstream/upload throttle.

EDIT: This was on a Puli AX (GL-XE3000) which is basically the same as a Spitz AX.

1 Like