Help troubleshooting tethering on X750V2 Spitz

I recently purchased a GL-X750V2 and I have been testing out the various features. First I wanted to make sure each of the internet interfaces work.

  1. Cable. Works fine
  2. Repeater. Works fine.
  3. 4G modem. Works fine
  4. Tethering. Internet access not working.

Here is what I have and what I have done. I am trying to tether an older Android phone (honor 8) running Android 7.0. My cell service is Google Fi. When testing the internal modem in the Spitz I just put the SIM from the phone into the Spitz and it worked fine. I can reach the internet. However, when I return the SIM to the phone and try to tether the phone to the Spitz I can connect just fine, but there is no internet access. In other words, from the Spitz interface I can select tethering and connect without issues. I just don’t have internet access on the Spitz wifi.

I have tested tethering with the phone on 2 windows laptops and both laptops can connect and reach the internet. I can also surf the internet on the phone while it is tethered to the Spitz. But any device connected to the Spitz via wifi does not have internet access.

Any ideas on how to troubleshoot what is going on?

Do you have another model of brand of smartphone that you can try?

Unfortunately no. My other phones are locked and won’t work with Google Fi. And the plans on the locked phones do not allow tethering.

Are you wondering if there is an issue with Android and Spitz? The phone I’m having issues with does do tethering with windows laptops.

Other forum posters have reported that some smartphones cannot tether to some routers because OpenWRT drivers may be missing for the smartphone hardware:

Hmm, interesting that others have seen a similar issue. But my case is slightly different and in fact makes me wonder if it’s something beyond a driver issue. The reason I say that is because I can connect to the Spitz, it is detected as a tethered device and all looks well from the interface. It’s just that at that point I can’t reach the internet.

Thanks for the link. I’ll cross post over there for visibility.

I replied you there Can not tether OnePlus phones with Flint - #11 by charliem

But pls just keep one thread. Otherwise I need to reply everywhere and that does not help to solve.

Yes, I agree, one thread.

Do you prefer to keep my issues separate? If yes, I will reply here. Otherwise I will answer on the other thread.

I don’t mind actually.

The usb0 device when tethering is

I don’t know if this useful information or not but I also did testing with the Honor 8 as a wifi hotspot. I set the X750 into repeater mode.

Windows laptop → hotspot = internet
iPhone → hotspot = internet
Windows laptop → X750 → hotspot = no internet
iPhone → X750 → hotspot = no internet

So when using USB tethering the IP is

What is the IP when using repeater to connect to the wifi? Same IP?

Do you have more info about the subnet? Maybe just a screenshot is helpful.

Also can you check the following to check if it is a DNS problem.

  1. Ping via your pc
  2. Ping via the router

Make sure the usb and LAN IP are DIFFERENT networks. (or whatever) on the usb0 and the LAN IP needs to be, example

Some devices aren’t assigned a USB network address by mfg so they pick it up from the first connection they receive. Mainly for plug n play compatibility. The problem is the router places them on the same network and that causes routing issues.

After setting that you’ll have DNS issues and won’t get a solid outside connection. You need to place the DNS as the gateway IP. The gateway is the phone itself. Use the gli Internet connection setting page to get the GATEWAY (NOT THE PHONE IP) and copy that into the “custom DNS” settings page.

If you still don’t have an outside connection then place the gli router, example from earlier “” (or whatever you chose for that router IP) into the DMZ (on the gli, placing the gli into ITS OWN DMZ!) to open all the ports automatically.

Lastly, because I’m a nugget for doing this all the time, make sure your mobile Internet is connected on the tethered phone and all WiFi is off! Helps A LOT!


Ps, and yes I did sign up JUST to help you on this. I had the same issue yesterday.

1 Like

Thank you all for your suggestions!

I believe I have configured the phone and the router as suggested but I am still having issues with internet access. I have NOT done the DMZ suggestion because I was not sure what IP address to use for the DMZ Host IP field.

lan_ip tether
The phone is called ‘Blue Honor 8’. This is repeater mode

Ping tests.
PC → X750 → phone - tethered
X750 → phone-tethered

Let me know if you see something I have missed or if you can think of any other tests. Also, if you can confirm what DMZ IP address I should use I will do that test as well.

Thanks again.

I tested with Honor X10, 3.211 firmware, and tethering worked fine.
Are you sure your phone has data switched on and is not connected to any other hotspot?

Gateway dns mismatch between the honor 8 and tethered GATEWAY. ALL extensions need to know the tethered GATEWAY as the DNS server.

To add another router to your network via the honor 8 the new router would have to be told that the gate way is the HONOR but the DNS is the tethered GATEWAY (Point of entry). The honor has the job of then forwarding that stuff to the gateway as data, not a dns query… (via ports).

So the honor needs the gateway as the GLI LAN IP and the DNS as the tethered GATEWAY. The IP of the honor should be THE SAME POOL as the GLI LAN IP. Eg 192.168.8.x and the GLI LAN IP MUST be different from the Phone IP POOL. If you still struggle I’ll have to screenshot some stuff…

Complicated I know but hey… I didn’t write the thing…

Let me know how you get on.

Please bear with me, I am struggling with the terminology in addition to doing a crash course on networking. I will try to explain how I am interpreting what you have written and I reference the screenshots above.

By no means am I complaining, I’m just trying to get clarity.

  1. tethered GATEWAY. That is the honor phone’s gateway, with IP
  2. To add another router to your network. My network is the X750 and I am adding the honor as another router?
  3. the new router would have to be told that the gate way is the HONOR but the DNS is the tethered GATEWAY. Again the new router is the honor. But, it needs to be told that the gateway is the HONOR. I don’t understand this if the new router is the honor.
  4. So the honor needs the gateway as the GLI LAN IP. Is this the gateway IP that shows up in the Tether screenshot above? Aren’t these values set by the honor?
  5. and the DNS as the tethered GATEWAY. The tethered GATEWAY is the honor and the IP address of the dns and gateway should match. Is this what is shown in the Tether screenshot above?
  6. The IP of the honor should be THE SAME POOL as the GLI LAN IP. Eg 192.168.8.x. Now here is one thing I was able to dig into. When looking at settings on the honor, with just cell data and USB connected to X750, the IP address for the honor is I do not see a way to change this.
  7. the GLI LAN IP MUST be different from the Phone IP POOL. The LAN IP is and the phone IP POOL is, so I’m good correct?

Thanks for your patience and help.

@luochongjun Thanks for your reply.

I made sure to turn off wifi and bluetooth. And then I have tested to make sure I could successfully reach the internet on the phone. So all is fine on the phone. I am running 3.211.

BTW, I can tether my phone successfully to a windows laptop, just not the X750.

-------images removed------------

You router is 4g, I didn’t realise. So all you need to do is give the devices connecting to it an ip in the same range and the rest point to the Gli as dns and gateway.

The Gli should then do all the internal switching. Basically dns and gateway are the way out of the building. Gateway is the door and dns is the list of doors available… In a nutshell…

Right, it should be pretty straightforward. And looking over your screenshots I seem to be similarly configured. All devices connecting to the X750 point to the same IP range as the router, what shows up in the LAN IP screenshot above. So, the network traffic should just pass through to the phone. But it doesn’t!

I don’t believe that the tethered phone is the problem since tethering works just fine on my windows laptop. Using ipconfig I don’t see anything different from what is shown above in the screenshots.

I removed you images because it contains private info e.g. your phone’s mac and sn.