How to configure WAN VLAN on MV1000 Brume?

Hello there,
I have a fiber connection at home and my ISP uses the DHCP protocol with some specific parameters:

  • WAN needs to be tagged on a Vlan on port 832
  • TV services (optional) use a vlan on port 840
  • Necessary to send identifying packets : for dhcp v4 : option vendorid, option reqopts, option sendopts,… and for dhcp v6 : option sendopts option reqopts,…

My problem is that i never succeed to make the WAN network up and running.
Here are below the steps i followed adapted from a working configuration (tutorial made for Turris Omnia router though) . Could you tell me if these commands are compatible with the GL-MV1000 or what i will have to modify ?

  • in /etc/config/network : [XXXXXXXXXXXXXXXXXXXXXX are for my ISP credentials in hex format, not an issue here, i know they’re correct]

config interface ‘wan’
option ifname ‘eth1.832’
option proto ‘dhcp’
option broadcast ‘1’
option vendorid ‘sagem’
option reqopts ‘0x01 0x15 0x28 0x51 0x58 0x59 0x90’
option sendopts ‘0x4d:2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7833 0x5a:00000000000000000000001a0900000558010341010dXXXXXXXXXXXXXXXXXXXXXX’

config interface ‘wan6’
option ifname ‘eth1.832’
option proto ‘dhcpv6’
option reqprefix ‘auto’
option reqaddress ‘none’
option defaultreqopts ‘0’
option sendopts ‘11:00000000000000000000001a0900000558010341010dXXXXXXXXXXXXXXXXXXXXXX 15:FSVDSL_livebox.Internet.softathome.livebox3 16:0000040e0005736167656d’
option reqopts ‘11 17 23 24’
option send_fqdn ‘0’

  • in /etc/hotplug.d/iface/ i created a file named 05-vlanprio with this content :
    #!/bin/sh
    set -x
    for i in 0 1 2 3 4 5 6 7; do
    /sbin/ip link set eth1.832 type vlan egress $i:$i >/dev/null
    done
    /sbin/ip link set eth1.832 type vlan egress 1:0 >/dev/null
    /sbin/ip link set eth1.832 type vlan egress 0:6 >/dev/null

  • in /lib/netifd/proto/dhcpv6.sh, i added “-a” on the last command in this paragraph :
    proto_run_command “$config” odhcp6c
    -s /lib/netifd/dhcpv6.script
    $opts -a $iface

  • added some rules in /etc/firewall.user . I don’t mention it here because i don’t think my problems came from this file.

Many thanks for your help because i’m completely lost now !

@arcadiabay You can add this part of config to /etc/config/network

config interface 'wan_internet'
        option ifname 'wan.832'
        option proto 'dhcp'

config interface 'wan_tv'
        option ifname 'wan.840'
        option proto 'dhcp'

I was able to do this through the GUI:
More Settings > Advanced > Network > Interfaces > WAN > Physical Settings
In the drop down enter Custom Interface: wan.vlan
Example: for getting PPPoE to work with CenturyLink, I needed to set this to: wan.201
Save.
Now in the drop down you should see “Software VLAN: wan.201” (wan)"