How to Detect Internet Pauses?

I'm having trouble with my internet signal dropping. By "dropping" I mean that webpages, streaming videos or uploading videos become incredibly slow.

I suspect this is a problem with my internet provider, but I wanted to use the Admin Panel of my GL-X3000 to diagnose and monitor the problem. Yet, when the problem is happening I do not see any change in the "Internet/Historical Signal Record"

This doesn't make sense to me because if I do ping 8.8.8.8 in the Terminal I see very high pings during the time when the signal is dropping.

Can someone explain?

The signal quality and strength has only a limited influence on the speed and reliability of the Internet connection.

Even on perfectly developed railway tracks (signal itself), delays and train cancellations (ping timeout, high latency) can occur - but this does not change the physical condition of the rails.

I regularly experience kind of pauses I describe.

Is there any way I can use my GLX3000 router to diagnose or track these type of situations?

I have two Sim cards in my GLX3000 from Internet providers in different countries in Europe. What is the best way for me to set up my system so that these Internet pauses will cause me the least trouble?

Thank you for your help.

I'm sorry, I don't have enough knowledge about the LTE/5G thingy to help troubleshooting here.
But I'll ping @Bruce he will do better than me :slight_smile:

Hi,

Try to update the firmware of the modem please, here is the guide:

Note: In the Step 2, use this url to wget:
wget http://download.gl-inet.com/download/RM520GL-modem_firmware/RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip

@bruce Thank you for the help but I have some questions:

  1. How do you know I need a firmware update to my GLX3000? The problems I described in my original post do not involve the GLX3000 -- it is a problem with the internet service provided in European countries. I'm just trying to make use of the GLX3000 to minimize this problem

  2. When I ran the first command in Terminal the response was
    zsh: command not found: wget

  3. I assume this means I need to install "wget" But, what is "wget"? Who makes this software? How do I know it's trustworthy?

Thank you

Run opkg update && opkg install wget on your router.

It's a pretty common package. See Wget - GNU Project - Free Software Foundation

@admon I don't understand what you mean here. Is there a command line interface on the router? If so, can you tell me where? Or do I have to ssh to the router as on this page? This is not the sort of thing I've done often -- I think the last time was 20 years ago and I just followed instructions to do it.

I'm on a Mac, by the way.

You need to ssh into the router for all steps, yes.

Just open the Terminal in mac and type ssh root@IP-of-the-router login with the Admin password then.

Thanks for the help. I followed the instructions and at the end it showed me the software version:
RM520NGLAAR01A07M4G_01.201.01.201

Did I do it right?

Hi,

Have not upgrade the firmware of modem, the latest firmware version is RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200

Please follow this guide to upgrade as following guide:

In Step 2, please use these commands to instead of the original commands:

wget http:// download.gl-inet.com/download/RM520GL-modem_firmware/RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip

unzip /RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip -d /RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200

For the SIM, you can also test on your phone directly.

I have two SIM cards in my phone, from two carriers. Both has good signals but one carrier is really bad. Speedtest is not good. High legacy. Even phone call breaks from time to time.

It is a cheap carrier though. It does not have its own infrastructure and needs to rent the towers from the other carriers.
The other one is very solid and have good signal and speed.

@Bruce This link you provided

Upgrade Quectel Module Software - GL.iNet Router Docs 4

is no longer working for me. Each time I click it I get a message which says:

This page isn’t working

docs.gl-inet.com redirected you too many times.

Also, checked my Admin > Settings it says my firmware is up to date (in Green):

Can you explain?

Thanks

@Bruce Now I can open the upgrade guide, and I tried to use what you suggested in step 2. However it didn't work. I tried several times. For example, here is my last attempt:

tony@mba Desktop % ssh root@192.168.8.1  
root@192.168.8.1's password: 


BusyBox v1.33.2 (2024-04-19 07:45:03 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02-SNAPSHOT, r15812+880-46b6ee7ffc
 -----------------------------------------------------
root@GL-X3000:~# cd /usr/bin/ && wget https://fw.gl-inet.com/tools/quectel_tool/QFirehose-
mtk7981a-sha256-c0b944
Downloading 'https://fw.gl-inet.com/tools/quectel_tool/QFirehose-mtk7981a-sha256-c0b944'
Connecting to 3.160.188.80:443
Writing to 'QFirehose-mtk7981a-sha256-c0b944'
Cannot open output file: File exists
root@GL-X3000:/usr/bin# chmod 775 QFirehose-mtk7981a-sha256-c0b944  && sha256sum QFirehose
-mtk7981a-sha256-c0b944
c0b944f62e5ef9e83a71775b494f96d661b0ffafa3490ddb901e460084cd0ffb  QFirehose-mtk7981a-sha256-c0b944
root@GL-X3000:/usr/bin# wget http:// download.gl-inet.com/download/RM520GL-modem_firmware/
RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip -P /
Downloading 'http://'
Failed to send request: Operation not permitted
root@GL-X3000:/usr/bin# wget http:// download.gl-inet.com/download/RM520GL-modem_firmware/
RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip
Downloading 'http://'
Failed to send request: Operation not permitted
root@GL-X3000:/usr/bin#

Also, can you explain is this the same as upgrading the Firmware in my GLX3000? If so, why does my Admin panel say my firmware is up to date?

Thanks

There is an typo in your command. Make sure that there is no free space between http:// and download.gl-inet.com

Should be

wget http://download.gl-inet.com/download/RM520GL-modem_firmware/
RM520NGLAAR03A03M4G_BETA_20240521C_01.200.01.200.zip

If you don’t know what are you doing I recommend to stop. You can brick modem, which is irrecoverable (cannot be restored via Uboot)

1 Like

When I have trouble with my ISP, I setup a small linux system with 'smokeping' (URL below) and configure it to a few domains, that are regional and some globally.
https://oss.oetiker.ch/smokeping/

Here you can see if and when the connection getting worse, based on simple ICMP pings, with nice graphs. Even if you need a system that provides at least a LAMP setup, it is less difficult than brick the router. If you don't have any raspberry or similar with ubuntu or similar image, you could just set up a virtual machine with hyper-v or virtualbox on your main computer.

Tony, if you are not very familiar with the command line, please test the sim card on the phone first, please put the upgrade process of the modem aside

As suggested, I stopped.

However, I never got an answer to the question in my original post. Can someone explain?

Thanks

Could you please refer to attached to bind the router to the GoodCloud, and share the device with us? We will try to check the issue you met. Thanks in advance.

Technical Support via GoodCloud.tar (192 KB)