How to enable Lan port on GL-AR300M?

Hello. I use a GL-AR300M hardwired to a hotspot via usb for my internet. I would like to hang another router off the GL-AR300M connnected to the LAN port but am having trouble getting this to work. Any pointers or is this not possible?

What do you want to connect to it?

If you just want more wired devices, it is a switch that you would attach to it.

If you want other networks to be attached, then a router is what you’d need.

If it’s not the first, explaining what you want to achieve for a network topology would help in explaining how to configure toward your goals.

I’m extending the network to a pole barn. I need wireless out there and am putting a new router with wireless ability out in the barn. I want to hook the lan port of the new router to the lan port of the gli.inet router. Can’t get the new router to work on the lan port of the gli.inet.

Is the barn router being used as a WAP or an actual router?

What’s the router on the other end?

Other thing is obviously to check is that you’ve got a “signal” from the AR300M, so throw a wired ethernet connected device (notebook, desktop) into the LAN port on the AR300M and make sure thats working :slight_smile:

You will most likely need to go from the LAN port on the AR300M to the WAN port of your receiving router…

Are you running an Ethernet cable out there, expecting to connect to your “other” wireless with the AR300M out there, or something else?

Limbot, I have tried both hooking a laptop up to the LAN port of the AR300M and hooking the new router from the LAN port of the AR300M into the WAN port of the new router and neither worked, thus my post.

jeffsf, that is exactly what I am trying to do. My issue is getting anything out of the AR300M LAN port. the AR300M does provide wireless signal to my other devices with input internet coming from the USB port of the AR300M. Maybe both ports can’t be active at the same time,… I don’t know.

BTW the LEDs on the LAN port never do anything when I plug my laptop into them. Not sure what if anything they are supposed to indicate.

Ok thanks for additional info. Just trying to establish where the “issue” lies. Assume you’ve tried different LAN cables to eliminate that as a cause?

You should be able to connect via wireless and LAN simultaneous so since the wireless LAN works its a AR300M hardware or config error… :thinking:

Just tried a couple different cables to try and isolate the problem. None of them work. What would the config error be? Seems like the documentation indicates that the LAN port would be on by default, no? The only thing that should need configuring would be if I wanted both ports to operate as LAN ports from what I see.

My firmware is 2.261

Mmm, my first suggestion would to be to update firmware to the latest version ( you’re a few releases behind (3.026) :slight_smile: )
https://dl.gl-inet.com/firmware/ar300m/nand/testing/

Then do a reset and reconfigure…

1 Like

Where are the instructions to do a firmware update?

For upgrading from your v2.x firmware you find the instructions here: https://docs.gl-inet.com/en/2/setup/firmware/

If you don’t manage, you might want to try Debricking your Router.

Just a notice: The testing branch of the v3.x firmware linked further up won’t work directly if you take the “debrick” route. In that case, you would want to debrick with v3.001 firmware img first which can be downloaded here.

All this reflashing, debricking, sounds like a lot of risk without knowing the reward. Does anyone know for a fact that the LAN port issue I am experiencing WAS a problem with earlier firmware? If others had a working LAN port on my older version of firmware, perhaps I will just quit while I am ahead and chalk this up to bad hardware.

Both ports should be able to be active at the same time, but you’ll need routing to tell the device which one to use, as well as potentially modifying DHCP to tell the clients where the default gateway is.

If you’re connecting the AR300M as a wireless AP, bridged to the LAN, then the “dumb AP” configuration is perhaps what you need. [OpenWrt Wiki] Wireless Access Point / Dumb Access Point

jeffsf, your first sentence is along the lines of what I need to do. It’s actually the second router that I’m connecting to the AR300M that will be the sort of dumb AP. Tell me more about “but you’ll need routing to tell the device which one to use, as well as potentially modifying DHCP to tell the clients where the default gateway is.”

I still don’t understand why I can’t just hook up a laptop to the LAN port of the AR300M and get that to work, while the AR300M does successfully broadcast internet over it’s WIFI.

Why don’t you just try a “hard reset” first. When turned on, hold down the reset button for like 20-3- secs. That would assist in identifying if it’s “just” a configuration issue… :slight_smile:

I don’t know how your “upstream” router is connected to the Internet. If it is directly connected, then what you likely need to do is:

  • Plug a cable from the router to the LAN port on the GL-AR300M
  • Give your GL-AR300M a fixed IP address on either a management VLAN (preferred for security, more complicated), or on the network that the upstream router gives out – so you can access it for management
  • Turn off DHCP, disable the WAN interface, and probably a few other things that you don’t need (as the upstream router is providing them)

Optional, if you need “outside” connectivity from the GL-AR300M itself (which is generally unlikely, except for installing packages)

  • Add a static, default route on the GL-AR300M to the IP of the upstream router’s LAN address
  • Add the upstream router’s IP as the DNS server for the GL-AR300M

I would be happy to do so. What should I try after this is complete?