How to Pass the Internet Access Portal

How do i pass the access portal that my campsite with my Beryl AX 30000?

Is there an easy way to do so?

This is the screen I get when I login directly with my mobile. When I connect the Beryl nothing comes up

Login w/ your mobile phone. Once online as expected, disconnect. Go into its Wi-Fi settings & look for that connect’s MAC.

Head to your Beryl’s AX settings & input the mobile’s MAC into the ‘Clone MAC’. See Solution 2:MAC Clone of if Solution 1 doesn’t work:

Some suggestions in this thread:

I do not work for and I do not have formal association with GL.iNet

1 Like

Thanks wcs2228 for your thoughts and explanation. I tried a lot of things yesterday… finally I got it to work

I got it working with the following method:

Connect a device to the camping WiFi.
Made a screenshot of the assigned IP, DNS, Gateway.
Disconnected the camping WiFi and clicked “forget Network”
Then I connected to the admin panel of my Beryl.
I searched for the WiFi network in my repeater setttings
Clicked on the settings wheel and manually added all the details.
After reboot my phone and Beryl I see the portal on the first device I connect to my Beryl WiFi.

All the other devices are connected to the internet now.


Are you able to please post the screenshots of these settings that you have manually entered into the Beryl as I have been really struggling to get the captive portal so show up despite trying a similar approach? Thanks in advance.

First I connected to the camping WiFi with my mobile, and checked the IP, GATEWAY, and DNS
Photo 1
Photo 2

Then I disconnected the Camping WiFi, and connect to my Beryl.
Then I add the same setting in my Beryl

And your done. Let me know if it worked for you


Many thanks indeed for the very helpful reply. I’ve had to unfortunately leave the campsite today but will definitely try your approach the next time I am there. Have you needed clone your phone’s MAC address into the Beryl as well or did you leave the default MAC untouched?

Thanks again for your help and I will definitely add your useful posts to my ever growing list of weapons to try and win this battle against captive portals (never had so many troubles with captive portal with any of my other network devices). Not really sure why the blooming GL.iNet would not pickup the parent router’s gateway and DNS details normally like any other normal networking device!!!

This is good to know. People need to start cloning ip/Mac/gateway as MAC cloning is not enough.

1 Like

I have been at a Marriott Bonvoy for the last week. And could not get my Beryl AX to connect. It would start up connect to Marriot WiFi as a repeater and would be happy thinking it was connected to internet but I could not get any internet. A captive portal login would not pop up as normal. I used a tablet and my luck. Tried to clone the luck. Finally I had some free time on day 5 of the vacation and decided to try with my WIN 11 laptop. As soon as I connected to the Beryl WiFi SSID (the Beryl was already setup to try to connect to the Marriott WiFi on power up) an Edge window opened up with the Marriott Captive portal and I logged in and I got logged in thru the Beryl AX.
I don't think I really learned much from this process. But I am connected to the Beryl as a repeater as I type this.

  1. Maybe try a laptop if none of your handheld devices work to get the captive portal?
  2. I even tried the GL.iNet application. No Luck.
  3. Apparently this Marriot is not acually blocking personal routers. It seems to be some problems that is keeping the Beryl AX from pulling up the captive portal like it normally does on my handheld devices.