How to use TCP 443 for openvpn on GLX750 Router


I’m using GLX750 LTE/$G Router and want to use TCP 443 port for openvpn connection. Can this be done on this router?


Pretty sure it should work the same as in the other topic you already asked :wink:

But not for incoming connections mostly, since you use LTE/5G.

I’m not using openvpn server, I’m using openvpn client and loading the configuration file from expressvpn. Here there is no option to change protocol or port!

I have no idea if I can/should use openvpn server with expressvpn!

Thanks for help!

You can’t change the port to 443 if you use only the client.
The port is provided by the OVPN provider - if they don’t offer connection to 443, there is no option to do it.

1 Like

thanks for the clarification. I’ll try to contact them and ask if they offer this.

Let me suggest you - they are pretty good and offer OVPN TCP/443 support.

thanks admon,
I just purchased a mullvad account and tried it out, somehow it’s still not working, I have installed the openvpn configuration file (with TCP 443) from their website, added a new openvpn client to my GLX750 router and uploaded the config file and entered the user/pass. When I connect it show an error that it can’t connected and then this:

Socket Buffers: R=[87380->327680] S=[16384->327680]

Attempting to establish TCP connection with [AF_INET] [nonblock]

TCP connection established with [AF_INET]

TCP_CLIENT link local: (not bound)

TCP_CLIENT link remote: [AF_INET]

Uhm, looks good to me. No error shown.
Ping does not work?

no, I get timeout error:

~ % ping
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
92 bytes from ( Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 f19d 0 0000 3f 01 6b4f

Could you try to use OVPN on your PC/smartphone - just to make sure that it works normally with your ISP?

on my iphone, only wireGuard works when I opt-in the “EireGuard obfuscation” obtion, this option hide the wireGuard traffic inside another protocol. But this feature sadly doesn’t exist when setting wireGuard on the router!

So you are currently inside a country with blocked VPN usage?
In that case it will be difficult.

You should go with the “bridge” servers listed here:
And make sure to read this article: Intro to Shadowsocks | Mullvad VPN

It might be impossible to run it directly on the router - I can’t tell for sure.