Huawei E3372h-153 not showing up in Brume 2 Webgui

I wanted to test a Huawei E3372 with v21 firmware (serial mode), so it works in serial mode. But it wont show up in the GLInet web interface for Brume 2 on fw 4.5.0:



Shouldnt it work out of the box? It has fw E3372h-153_21.

When I manually add this to /etc/network:

config interface ‘wwan’
option mode ‘preferlte’
option apn ‘internet.telekom’
option dialnum ‘*99#’
option username ‘telekom’
option password ‘telekom’
option proto ‘ncm’
option ifname ‘wwan0’
option device ‘/dev/ttyUSB1’
option ipv6 ‘0’
option metric ‘40’
option delegate ‘0’
option disabled ‘0’

with /etc/init.d/network reload I get this for ifconfig:

But cant ping through it. It also doesnt seem to get ipv4:

udhcpc --interface=wwan0 -q
udhcpc: started, v1.25.1
udhcpc: sending discover
udhcpc: sending discover
udhcpc: sending discover

and stops

Logs show this:

not sure what wwan_4 is it is not shown under ifconfig

Log shows 3 times again this

Thu Jan 25 01:30:29 2024 daemon.notice netifd: wwan_4 (3473): udhcpc: sending discover

and doesnt get an IPv4 ip.

There are currently issues with 3372 support, which is not fully matched yet.

I found this post with also a similiar issue:

“LTE module does not support DHCP so it must be configured via QMI.”
you must change the default value of
“dhcp” option in QMI protocol configuration options from 1 to 0 so the system is using uqmi and not dhcp

How will UQMI handle the assignment of IP address and route? The stick is fine, driver fine, connection working, but the last step is just broken, and it wont get a IPv4 because of some DHCP issue.

Here is a similar issues discussed 9 years ago: [OpenWrt-Devel] Huawei 3372 NCM support on CC not working it was said being fixed in kernel 4.2? how come it doesnt work though.