I have problems, My hardware is “GL-MT1300 Beryl“

Hello, I have problems.

My hardware is “GL-MT1300 Beryl“

Problem 1, No SD-Card (TF) Setup in Firmware “Beta 4.2.3“ and FW. “Snapshot 4.3.6“?
Problem 2, Web Admin (GUI) No DE in Firmware “Beta 3 4.1.0“?
Problem 3, LED Setup, the storage remains only in the FW. “Beta 3 4.1.0“ Receive?

I’ve tried everything, reset via GUI & Luci, also directly on the device 30Sec. hold-turn off-still hold 30Sec.like in your video.
fw Reset, no change?
Also to the FW. “3.2.15” Back via Luci, since it is not allowed in the web/admin, unfortunately without success?
Request for help, thank you!

These problems only occur since FW. “Beta 1 4.2.3” on, you can’t reset it like it used to be right?

The pictures were taken for a better understanding, the errors are described there including the firmware.

State is now FW. "“Beta 3 4.1.0” Web/Admin only in EN No DE?

I also don’t understand why I can no longer access the SD card (TF)?

Under Luci you can see the language packs in the FW. which is installed in FW. “Beta 1 4.2.3” there are 6 (there is Web/Admin also in DE) but in FW. “Beta 3 4.1.0” is only 3 DE (Web/Admin EN No DE) I can’t install more under Luci?

All packages were also updated under Luci, I only installed standard, no extra packages except language DE.

Luci Paket Aktuall. No GUI Luci Yes

Sven Hornung

Hello Sven,

I’d really just re-flash/completely overwrite your Beryl w/ a stable version of the firmware via U-boot. Sometimes beta builds, never mind snapshots, just aren’t worth it as you’ve found out.

1 Like


Thank you for your quick response.

Had no other problems with your very good hardware.

The Fw. 4.1.0 also ran great for me, and Web/Admin (GUI) was also in German.

Only since changing to the current FW. Beta 1 4.2.3 do I have these problems and unfortunately I can’t get it back?

Thanks for pointing out the videos, I’ve tried everything but it doesn’t work anymore.

That’s why I contacted you.

I leave it as it is now, I can work with it, only with the restriction that WEB/Admin (GUI) is set to EN and access to the SD card (TF) is no longer possible.

Then continue to use the FW. Beta 3 4.1.0, the most important Yes, it works from iPhone Hotspot WLAN 5GHz.

All the best to you and thank you again!


Sven Hornung

1 Like

I’m not a GL.iNet rep; I’m just another happy user of their hardware like yourself.

If you can re-flash your Beryl using the Uboot method, you’d be able to set the language at the ‘first time setup’ though I do not know if German/DE is specifically listed.

If you don’t want to I understand; I would check for stable firmware updates regularly though.

1 Like


many thanks for your help.

Please excuse my bad English.

I do that regularly according to current FW. To look for release but the FW. 4…. is not in release yet.

I really tried everything to flash, unfortunately it no longer works for me like it did before with the FW. Beta 3 4.1.0 true and I don’t understand this?

Kind greeting

Your English is better than my German.

Firmware Version 3.216 is the latest stable build for the Beyrl (GL-MT1300). It can be used for the Uboot recovery method. I would use it & the Uboot method to reset your Beryl as if it was a brand new device.

This may help:



Yes, I had done that several times, as already written.
This FW. 3 … is not of much use to me, that’s why I have the FB. Beta 3 4.1.0, because almost everything works, just not like it used to be, the web/admin in DE and no access to the SD card (TF).

Kind greeting

1 Like

Version 4.1.0 is older and we haven’t tested it much.
You can try the latest 4.3.6, which is being tested.
GL.iNet download center (gl-inet.com)


Thank you very much for your email.
I have already tested that “FW. Snapshot 4.3.6" as written, the option/setup of the SD card (TF) is gone.
The Fw. Beta 1 4.3.6 is the only one that works for me, but unfortunately it can be used with restrictions.

Kind greeting

Beryl only have 32MB flash, so It’s not enough to pre-install these features.
You can exroot your Beryl and install gl-sdk4-nas-web & gl-sdk4-nas-utils.

1 Like


Thanks for your help.
I had never tested/run this exroot.
I would have to try it out, unfortunately I have no experience with “exroot”.
I don’t use any extra packets, including VPN, which only takes away speed anyway. Just like I got the Berly without extra packages, just what was on it.
Only use the function, WLAN 5GHz hotspot from iPhone to Berly, so that I can use 5G or LTE.
I had the FW. Beta 3 4.1.0 times in Web/Admin on DE, EN also works, no problem.
I still have to test the access to the SD card (TF) for the purpose of the mount point.

But what is very strange, when installing the current beta FW almost everything was OK but,
After updating the packages via Luci, I was no longer able to access the Web/Admin (GUI), nothing worked there, as you can see in the picture, only a white screen in the browser with the error message.
Also have other browsers Tried the same?

Kind greeting

Is it the same with mobile access?
Do you know how to use SSH? If you have an SSH client, connect to the device and use this command to check the web server status.

ps | grep nginx
netstat -pan | grep :80
1 Like


Thank you for your info/help.
Mobile not possible at the moment, because I only have 1 mobile contract and this is then connected to Berly via 5G/LTE.
As already written, I have di FW. Beta 3 4.1.0 back on it.
SSH yes, here is the result!

Kind greeting


Had on FW. “Open WRT GL-MT1300 FW. 4.3.6 Beta 2 (Release 2)_20.07.2023" Up. want.
Now I no longer have access even with a reset like on these videos, it was done several times, it doesn’t work anymore?
The white LED lights up, nothing more.

With kind regards

Did you keep the settings when you upgraded?
Please refer to the documentation to reinstall the firmware
Debrick via Uboot - GL.iNet Router Docs 4 (gl-inet.com)


Your hardware is unfortunately not as good as Beta FW. concerned because you always refer me to the videos?
I’ve done these videos more than 50X with no success and so my berly is shattered.
I cleared it up with my supplier (he’s more powerful than me) because you’re not able to do that, it’s a pity, I would also buy new hardware from you and I can’t think of beta on your hardware anymore because it’s only causes problems.
Excuse me, but I have well over 30 years of experience in the network sector, but your hardware was new to me, you can’t know everything, which is why I turned to you.
Unfortunately, my English is very bad, as I mainly only need business English, I’m very sorry if you don’t understand me, please write to me, thank you!
Don’t want to badmouth your hardware, as already written, I would buy a new router from you, but you don’t exactly make it easy for me to believe in it, something can always go wrong, everything is normal, but always just refer to videos, what is this for a help please?

If you don’t understand something, please write me, I don’t mean it badly, I’d rather work with you than against you!!!

Sven Hornung

I am very sorry about that.
However, it is important to note that

  1. we never make any promises about the stability and usability of the beta version, it is more for old users and DIY users who need to try out new features. We never recommend using the beta firmware in a production environment.
  2. For the network storage on MT1300, which is not pre-installed, we provide a channel to install it at the request of some users, but we do not guarantee that it will always be available. It is not pre-installed because the hardware does not support it. Anyone who needs to use it should purchase a product that supports it.
  3. For anyone experiencing basic usage problems with the stable firmware, the best way is to send an email to support@glinet.biz.
1 Like


I have now ordered the GL.iNet GL-MT3000 (Beryl AX).
This one has a bit more than its predecessor.

My old Berly came back, it’s probably a mistake from the shipping company, I was able to clarify everything with my supplier (Amazon).
So I get to keep Old Berly.

Was very satisfied with this device but unfortunately the FW. flash what happened?
I can’t get to web (GUI) anymore, as I’ve written, I’ve tried over 50X with your video with no success?
Rest button works yes, it flashes green, I keep pressing reset, it lights up white, I let go of reset but unfortunately nothing else happens?

I’m the type of person who doesn’t give up easily.
Warry Nice Happy, Old Berly lives again.

Sven Hornung

Please check the Wi-Fi SSID of your GL-MT1300 after power on. If there is no Wi-Fi signals been lunched,Maybe the device has been broken.
Also,you can connet the lan port of the router to your computer with an ethernet cable.Check the IP address of the computer (default by DHCP,subnet 192.168.8.x If the computer can not obtain an IP address,There will be 169.254.x.x means the router working abnormal.

1 Like


GL-TM1300 (Berly) Working again, all good.
Many thanks for your help!