Internet browsing slows down on GL X3000 vs Phone

I’ve been hotspotting from my phone then decided to get the GL X3000 to relieve said phone. I took the same SIM from the phone, inserted it into the router, let the auto setup complete and I was connected to the internet again.

Problem here is that several websites that I frequent is now no longer loading. I’ve tried

  1. checking the APN name, they match
  2. rebooting the router, same thing
  3. resetting the router, nothing changed
  4. band masking, no dice
  5. swapping SIM slots, still not loading
  6. sticking the SIM back in the phone, websites loading normally again

The last step tells me that something’s up with the router that’s causing this. Anyone experienced this before?

Thanks!

Clarify; browsing to some websites is slow OR you can’t load these website at all?

Two things to verify:

  • upgrade your firmware to latest stable release
  • make sure that the bands your phone connects to identical to the ones the router connects to

Use fast.com for testing on both devices.

I’m talking about certain websites won’t load at all and others experiencing a noticeable lag when the SIM is in the router that loads perfectly fine when it’s in the phone.

  1. yes the firmware is updated to the latest one already
  2. the same band is used for both devices

If certain websites, does that mean the other ones are working fine?

Have you enabled any application/services on the modem e.g. ADGuard? Or using the default configurations?

Lastly, did you check the TTL?

Yes, other websites are fine though there’s a little lag before the pages start loading that’s not seen when hotspotting through the phone.

No AdGuard or things like that, everything’s on default.

I didn’t touch TTL yet as I don’t know what value to use. Any suggestions?

Try 65 TTL and reconnect to the cellular network.

Tried it…didn’t do much difference. Anything else I could try?

How did you verify that the phone and router were connected to the same bands? And please share your connection signal readings from the cell info section.

One more thing try to set the IMEI to that of the phone.

Read this as it may help GL-iNet GL-X750V2C4 Spritz 4G LTE being throttled after hotspot full speed allowance

1 Like

I used an app called Network Cell Info on my phone to get the band then enabled band masking on the router to connect only to the same band.

image

Thanks. Make sure that both the LTE and 5G match what your phone connects to.

Experiment with TTL and the IMEI, as mentioned in provided link.

Flush your dns on hosts connected to the router.

Share your result.

Can confirm that switching the IMEI to that of the phone did NOT resolve the issue. I tried IMEI from another phone I have lying around and that also didn’t work.

The websites that couldn’t load errored saying the page took too long to respond. Is the router somehow blocking the connection? Or could it be that the SIM somehow knows it’s in a router and blocking things?

Could it be a DNS thing? I pinged the websites that won’t load and received a response from them but they just won’t load in any browser.

If you can ping them by domain name it’s not an DNS issue.

How are you connected to the router WiFi or cable ? Do you have another machine connected to the router ? If yes, can you try browse to the same website?

It’s the same using Wifi or cable, on all machines/phones connected to the router.

I found this reddit thread documenting the same phenomenon Issues with new internet connection- only some websites will load : r/nbn (reddit.com).

I don’t have IPv6 running and only run 2.4Ghz Wifi. Tried changing DNS (Network > DNS > Mode > Manual DNS), that didn’t work either. But I don’t think it’s an ISP problem because things work fine when hotspotting from my phone.

Finally solved this problem for me, it was the MTU size. The packets were probably too big and got fragmented during transmission.

Followed the steps here What is MTU Size and What Should I Set it to? - Home Network Admin to determine my optimal packet size and now everything is back to normal.

1 Like

Great job :clap: !!! Wasn’t 1500 by default?

It was blank by default

It’s a valuable experience. Could you share with us which operator SIM card you’s using, and what MTU size you set finally? Thanks a lot.

I’m using Optus from down under and 1452 was the final MTU setting. This setting might not work for everyone but they can find the right one following the steps in the link I provided earlier.

Thanks a lot. If someone meets the similiar issue, this steps may help him.