IP Address Changed, Travel Router Stopped Working

A couple days ago I tried logging into my company laptop. I first need to connect to my company’s VPN. This laptop is connected to a Slate travel router via ethernet connection. I have a home server set up using another GL.iNet router that’s connected to my Xfinity gateway, so my location always shows I am at home no matter where I am located. This set up has been working fine the past week.

However, I was unable to connect to my company’s network and could not figure out why. The connection kept failing and I was really frustrated because I had urgent meetings that day. I went into the VPN dashboard for my Slate travel router, and it said “The client is starting…please wait.”

I then went into the setup page of my home server router, and I noticed the IP addressed changed!! So I figured this might be the reason it wasn’t working. I copied the new IP address and went into the Port Forwarding page of my Xfinity router and replaced it with the new IP address. From that point on it worked and I was able to connect to my company VPN.

What do I do from here? It seems like it would be a huge pain to have to manually go in and update the IP address every week or so. Is this a matter of having to request a static IP address from my ISP?

Are there any workarounds? Is there a setting I can change that will deal with the constant IP address changing? I have already Enabled DDNS for my Home Server router…I thought that was supposed to solve the issue of changing Ip addresses?

How safe are static IP addresses? Doesn’t that make it easier to get hacked?

Sorry for all the questions I’m pretty new at this stuff.

I use DDNS for vpn clients to connect back to my home network. But DDNS takes a little time to distribute as DNS servers will cache entries to lower network traffic. But to really know, it would be helpful to better describe (or draw out) the connectivity. I hate to guess and it is not entirely clear to me based on your description as posted without having to guess a little.

Do I need to enable DDNS on both the Travel Router and the Home Server router?

Right now I only enabled it on the Home Server router.

I just went into the admin panel of my home router (using a Flint for that). I went to Dynamic DNS and did a DNS test.

It said: The IP address from DDNS domain resolution is not the same as the WAN IP of the device. You need an Internet Public IP address to use Dynamic DNS.

Crap…what does this mean? What options do I have?

You can use your own DDNS client and service, you don’t have to use good. It will be a little bit of work, but there should be a ddclient package you can install. As an alternative, you can install an app on a client machine behind the router that will also register a ddns change for you. There are a lot of choices out there. I have not used the client built into the interface, so I can’t really answer any specific questions about its usage. I am using FreeDNS for my DDNS service. You can do it with a free account and they have a LOT of client options and directions. There are a bunch of choices, though.

You should only need it on the server side.

1 Like

I have exactly the same issue. My device ip changes every week or month. I had to do port forwarding again in order to work. I work abroad and it’s a pain if it’s stop working. Can anyone can help or suggest a new way to tackle this issue ? Thanks

1 Like

Didi your home IP changed (xfinity? or did the IP of the home vpn server (flint) change?

If it’s the former you should not need to redo the port forward. Can you clarify?

But if it is the latter then you need to redo the port forward. But this can be easily solve using static IP or IP reserve.

You should use ddns if it is the first case. You can use ddns on your xfinity or flint. Only one is necessary because both will resolve to your home IP. Only need to replace the Wireguard endpoint with your ddns.

Which IP address pls clarify.

Yes I think the virgin media ip address could have probably changed. I just removed the port forwarding rule, created a new and updated with the new ip assigned to my opal router which now working. However it will stop working if the assigned ip changes. I will check and let you know soon

The IP assigned to my opal router in the connected devices on my home router page.

You don’t use static IPs?

No I don’t have static ip

Did you use cable to connect the Opal to your xifinity? Try use a static IP.

No I use wifi wireless .Can I connect using a lan Ethernet cable ? Will it give a static ip ?

Static or not depends on the network configuration.

When you connect using Ethernet, you can choose that you want to set up a static IP instead of using DHCP. Same for Wi-Fi but only via luci in that case.

You should check the upstream DHCP router too - maybe you can set the lease to static there.

You can set up static IP if you use Ethernet cable and it will work.

It was the IP address of the Flint router that changed.

I then had to go into my xfinity router’s settings and manually update the Port Forwarding rules so the IP address matched the new Flint IP address.

So I need to use a static IP or IP reserve then? Can I do that within the Flint settings?

Use static on the Flint.

I contacted my ISP and they only offer static IP addresses for Business customers and not residential customers.

Do you know of any other workarounds?