Issues with the Gl-XE300-022 Puli

Hello all, I need help understanding and implementing the following:

I own a GL-XE300-022 Puli celular router. I have the same story as many. I am a Visible customer and can’t seem to get my connection straight when using my router. I have tried a wired tether, a wifi tether, and inserting the SIM directly into the device. I have manipulated hop limits, TTLs, and MTUs, but everything stays throttled at about 5 Mbps. The connected device I am using is a MiFi 8800l.

Here is the part that I need help understanding. My Windows 11 laptop is set up in the command prompt with “netsh in ipv4 set glob defaultcurhoplimit=65” and “netsh in ip64 set glob defaultcurhoplimit=65”, and when I connect to the MiFi, I steadily get 15-50 Mbps with or without a VPN.

What is the difference between the packet from my laptop directly into the MIFi 800l and passing that same packet through the gl.inet firewall?

How do I configure this router to do whatever my laptop does?

I can hotspot through my laptop and similar speeds on all my devices; however, my computer needs to be restarted every couple of days if it starts getting glitchy, so setting up this router would be preferred because it can stay on 24 hours a day and maintain a constant connection to my VPN. I am pretty close to giving up, and at this point, I’m starting to wonder if it might be easier to root a cheap Android device, install Linux, and then have Linux act as my custom firewall for my internet. Still, my instincts tell me that might be more trouble than it is worth.

I thank you all in advance for any information you pass along!

Frankly your description is vague. Can you reword what are trying to achieve!

When I connect to the MiFi 8800l, my PC data is not throttled. However, all other devices in my household are throttled. When using the XE300, everything inside my household becomes throttled. The only configurations made to my laptop are the IPV6 hop limit set to 65, and the IPV4 TTL set to 65.

On the XE300 I’m running the firmware that came stock on the device. In custom firewall rules, I set the following:

iptables -t mangle -I POSTROUTING -j TTL --ttl-set 64
iptables -t mangle -I PREROUTING -j TTL --ttl-set 64
ip6tables -t mangle -I POSTROUTING -j HL --hl-set 64
ip6tables -t mangle -I PREROUTING -j HL --hl-set 64

I also installed NordVPN and configured it according to Nord’s recommendations.

I ran three different configurations on the XE300 in router mode:

8800l tethered via USB to XE300
8800l connected via wifi to XE300
XE300 with Visible wireless SIM installed

After each configuration, I would ping the XE300 and verify that the TTL was coming back at 64. It made no difference. Data was Throttled to 3-5mbps.

For testing purposes, I installed NordVPN on my PC and then configured my PC as a hotspot. I then connected it directly to the 8800l, where data instantly jumped back up to approximately 20-60 Mbps on all devices connected.

I concluded that there is a setting inside the XE300 that is alerting my ISP to throttle data. A setting my Windows 11 laptop does not have. It is my guess that if I can configure the XE300 to connect to the 8800l the exact same way my PC does, I could resolve the issue. I am a novice, so I apologize for my lack of conciseness.

So you’re saying when you connect your pc directly to MiFi to the internet the speed is
Ok ?

But when you connect your pc to XE to MiFi to the internet the speed is throttled ?

For my understanding TTL on the XE should be [TTL on Windows]+1

So 66 instead of 65.

Correct, and he does not need to manually do it on iptables as gl. Inet allows the TTL to be set from the web interface in the cellular profile.

That is correct. My Windows Mbps is 20-60 without the XE300. When I incorporate the XE300 my speeds drop to around 5mbps.

Disable the vpn till you make sure it is working as expected then set up the vpn.

Btw, what if you connect your pc to xe to the internet ? Is it working ?

Speed stays throttled with VPN running and without the VPN running. With PC → XE300 → 8800L data stays throttled. I have tethered via WiFi and USB. I ran TTL/HL on PC at 128, 64, 65, 66, and 88. I also set the same values on the XE300 (128,64,65,66,88) . I tethered the XE300 to the 8800l using a USB cable. I tethered the XE300 to the 8800l using WiFi. I also removed the Visible SIM and installed it directly into the XE300 and tried all the and tried all the TTL/HL values again. I also left the TTL/HL values unchanged. With every configuration my data reminded throttled. The only time my data has not been throttled is when my TTL/HL have been globally modified on my PC, set to 65 and the XE300 removed from the equation…

I can run all other devices unthralled only if I connect them to my PC via hotspot and run my VPN

So did you set TTL 66 on the XE300?

Let’s do one thing:

Remove all configs you set on xe. Then connect the xe to MiFi. Next ssh into you xe from your pc and download a file from the Internet using curl or wget so that the connection is initiated from the xe to MiFi to the internet . Is it throttled?

Here is the command

wget -O /dev/null

I did set the XE300 to 66 on each configuration, reset the firewall and ran a speed test. Data reminded throttled

Use with pc directly connected to MiFi and share the result

Please remove all configuration on windows before the test

I will give this a shot once I am back home(three hours from the time you receive this message) and report back i am truly grateful for your assistance.

Copy that and will do

-The file that you sent took over 20 minutes to download.
-I factory reset the XE.

  • I factory reset all PC network settings
  • I disabled VPN on PC
    -VPN on XE was wiped in the reset
  • I attached a screenshot of my PC speed test after the network reset.

Here is my speed test while downloading the file you attached with everything reset

I did not say XE. I said MiFi so that we can know the speed of your connection before introducing more hops along the path.

I beg forgiveness for the uncertainty, picture 1 is speed test run pc → Mifi

Picture 2 is speed test PC → XE → Mifi initiated with .zip via SSH inside router