MiFi bricked after update

Hi, I updated my mifi today through the web interface and it never came to life again. It said the download was verified but something clearly went wrong.
I’ve been using the mifi for about a year now on and off, both as a repeater and as a 4g modem without any problems whatsoever.
Unfortunately after this latest update I just get a red power light now and can’t access the web interface any longer. There is no longer a SSID being broadcast and I cannot connect to Luci through the Ethernet either. I have tried to reset it normally to no avail and followed the instructions here Overview - GL.iNet Docs
Holding the reset in while booting causes the 3G/4g light to flash 10 times and although I seem to connect to the router (under Linux and also as ‘Unidentified Network’ under Windows) I cannot access http://192.168.1.1 in a browser or even ping it.
I don’t really fancy posting it back to China, and anyway my warranty is probably up, so can anybody tell me what options are open to me to try and unbrick it? Thanks :slight_smile:

You should hodl the reset in while booting causes the 3G/4G light to flash 5 times, not 10 times.

No mine flashes 10 times. I checked several times. That’s why I mentioned it because I had read somewhere that it was supposed to be 5

you are operating wrong in uboot.

You need to release your finger when it flashes 5 (or 6) times, when a 2nd LED flashes.

If you hold it longer to 10 times it will not enter uboot failsafe.

Yes, taking my finger off the button after 5 flashes of the light worked straight away. I can’t believe I didn’t think of that myself! Thanks very much :slight_smile: