MT-3000 won't connect to some 5ghz networks [SOLVED]


I’m having a similar issue as the one described in this post, with an anomalous twist.

I’m on the latest stable version (4.2.3) and my MT-3000 is not able to connect or “see” 5ghz only wifi hotspots from my OnePlus devices.

The router can see and connect to 2.4ghz hotspots from OnePlus devices (I tried a 10Pro and a Nord CE 2 Light), regardless of the WPA settings (I’m using WPA3, but I switched them all). When I switch them to 5Ghz, they won’t show in the “join wifi” menu or they will show as unavailable in the saved networks section.

Here’s the twist though:

the MT can see and connect to my home’s 5ghz only wifi, which is provided by Unifi Wifi5 APs. My home wifi is 5ghz only, my guest network is 2.4ghz only and both are seen by the MT.

I realise this is a bit of an academic issue since I do have connection options, but I wanted to report it to the devs and the community, in case someone else has the same issue or similar.


You can try setting different country codes via luci. Different regions have different restrictions on dfs channels.

Generally band1(36——48) is supported, you can set wifi to band1 channel range.


Thanks for taking the time to check in. My OnePlus devices were both broadcasting on high-numbered channels (130 and above) and my MT-3000 was set in Luci for my home region, which doesn’t support those high channels.

I managed to get everything working as expected by switching my 5ghz setting in Luci MKT to US: now my 5ghz hotspots are “seen” and the connection works great.

I don’t know if I can set my OnePlus phones use the 36-48 band for their hotspots, which would be optimal: there doesn’t seem to be a switch for it in the OS. Anyway, as far as Gl.inet, all is good.