Beryl AX cannot connect to my existing Wifi

Hi all,
anyone experience an issue with Beryl AX (MT-3000) having issues connecting to an existing WIFI network
using 5GHz 11a/n/ac mixed , Chanel width: 80MHZ, Channel 149. which are the default settings.

It can connect to that router via Ethernet cable. It can connect to my phone’s hotspot WIFI but not the router’s 5GHz network.

Already tried the 2.4GHz network as well to no avail. Factory reset the Beryl AX , issue persists.
Already own a Beryl (MT-1300) that connects no problem.

Anyone has any ideas ? please share.

1 Like

What firmware version is running on the Beryl AX? Try upgrading the firmware.

I do not work for and I do not have formal association with GL.iNet

It has been upgraded to the latest firmware provided: Version: 4.1.3 .

My wifi issues were fixed going to a recent snapshot version.

I upgraded to Firmware 4.2.0 beta2 to get connection to 5GHz wifi working. The 2.4GHz wifi still does not work, but I do not use that for repeater anyway.

You can try a snapshot firmware as suggested by @elorimer.

I recently got a Beryl AX MT-3000, set it up like my Slate AXT1800 (now sold), but it’s a wee bit disconcerting that you need to go to a snapshot (beyond beta) to get simple WiFi working.

Whilst the support team work pretty hard (and their efforts are appreciated) and do make pretty quick and regular F/W updates, would it be fair to say that in an effort to get products to market some of the stability of the supporting fimrware is being left behind?

1 Like

Thanks @elorimer @wcs2228 Tried both the latest and only snapshot and beta firmware available from the website, reset the device to factory settings. I can see the wifi networks but can’t connect to it. No luck thus far. The error message is : Connection failed, will retry later… While attempting to reconnect, your router will periodically scan for Wi-Fi networks, and your guest Wi-Fi network will be temporarily unavailable during the scan.

Could you export the full log?

@hansome there u go (25.5 KB)

I get the same. Did you fix this?

Generally works for me now, I use a recent snapshot, changed the country code (only) using WinSCP to give me more channel options and found it to be better (when trying to connect repeater mode) in the Webadmin rather than the GUI (especially for captive portal Wi-Fi): the GUI asks for a password for some reason.

Please try the most recent beta(4.2.0 release1) or snapshot firmware, which has a driver update.
Also kind reminder @DogAnguris

This still doesn’t work after upgrading to the latest 4.2.0 stable, snapshot or beta firmware.

Her I can connect to my hotspot iPhone 13 Pro Max wifi 2.4 Ghz but can not connect to 5 GHZ channel 149, 80 MHz, WPA 3.

Tested with de last stable release, beta, snapshot.

I can connect all my appliances to 5ghz hotspot of my iPhone.

My issues have been addressed in the latest snapshot as of 03/07
I can now connect to both 2.4 and 5GHz to my existing WIFI.

Thanks @JerryZhao and all who contributed.

I can not connect to iPhone hotspot in 5 5GZ with the last snapashot 2023/03/07. Only 2,4 GHZ

Tested clean install, router see my Wi-Fi accept the password but can not repeat the signal or connect to my iPhone.

iPhone 13 Pro Max.

No problem connect to iPad, MacBook, Apple TV.

My problem persist. I can connect router as client to other wifi 5GHZ not the one created iPhone hotspot.

Do you get any error messages and can you share the logs? (24.0 KB)

Glad you found a solution, always nice to have that ‘Eureka’ moment :slight_smile:

Having said that, whilst the support guys on here work their butts off all hours trying to help, I am still a bit disturbed by simple networking such as repeating i.e. neither bleeding edge nor complex usage often being ‘solved’ by snapshot firwmare, clearly marked as “…it’s not stable…”.

I really do not think this is a reasonable way for GLiNET to operate, if indeed upgrading to snapshot firmware is the only solution (which in some cases it might not be, issues may well be due to user setup error too, it is only fair to acknowledge that), particularly when these simple functions are part of GLiNET devices selling points.

They are by and large nice devices with lots of functions and (for the experts) enormous flexibility by way of firwmare changes and package addons, but in my view, if GLiNET wants to move them more into the mainstream for Home, Travel, or RV use etc. they might want to consider ensuring their base functions are working and are super-well supported in beta, if not stable firmware.

my 2c.


Hi,This is a bug,developers are working on the fixing it and will let you know asa it is finished.