MT1300 6in4 he.net tunnel

I’ve been trying to use the 6in4 package with luci for hours, and it doesn’t seem like the 6in4 adapter is working.

The “henet” adapter I set up doesn’t seem to ever activate or choose the WWAN adapter as the ipv4 interface.

Here’s contents of my /etc/config/network:

config interface 'henet'                  
    option name '6in4-henet'          
    option proto '6in4'               
    option peeraddr '216.x.x.41'  
    option ip6addr '2001:470:35:A::2/64'
    list ip6prefix '2001:470:36:B::/64' 
    list ip6prefix '2001:470:AAAA::/48'   
    option tunnelid '123456'              
    option username 'username'             
    option password 'update-key-here'    
    option ipaddr 'my.public.ipv4'

On my interfaces page in luci, I see the “HENET” interface, but it shows as red and rx/tx 0 bytes.

What do I have to do to make 6in4 work properly on the MT1300? :cry:

I am willing to use beta firmware if that means 6in4 works.

Has anyone gotten 6in4 to work on gl-inet devices?

Go this to work yesterday.
You have to enable the GL.INEtIP6 support in the GL.INET interface. You will notice the lack of 6in4 tunnel option in the config here.
You can confin the tunnel in the openwrt advanced settings, good guide at [OpenWrt Wiki] Setting up an IPv6 tunnel using LuCI

The problem comes on reboot. The GL-INET initlaisation will change the protcol of WAN6 back to what ever is in the GL.INET config for the WAN6 interface. You can manually switch protocols in the Luci web interface, it seems to remember everytrhing except the routing prefix (the /48).

I am using a WWAN WAN interface, and added a WWAN6 interface, I can build a tunnel on this no problems and it comes up after a reboort. So tunnel of WWAN works, without the GL.INET services “trying to help”. After I created the WWAN6, I noticed there was 2 devices in the GL.INET interface.

I made sure my GL.Inet was affecting WAN, so it left the WWAN6 alone to build the tunnel… I am guessing you can create a dummy WWAN6 interface, and change the device in the GL.INET t WWAN, to leave the WAN6 config intact.

I’ll see if my theory for dummy WWAN6 works, and update ticket.

Simon

Love replying to myself :slight_smile:

Just confirm, this is how I can set tunnel up.

  1. In LuCI create an IP6in4 tunnel using the link in my post above, and call it WWAN6 or WANT6 or something.
  2. Enable IP6 in in More settings in the GL-INET web interface.
  3. Reboot

The GL.INET interface only controls the config of the WAN6 interface, so if we crreate another interface adn use this for our tunnel, GL.INET leaces the config alone.

Simon

2 Likes

Thank you @smiths !

I tried your steps, named the IP6in3 tunnel WANT6, and left the “firewall” setting “unspecified”.

No traffic seems to be going out the WANT6 interface.

Did you do anything else in your config? What is your “More settings > IP6” settings like?

Thanks!

EDIT: I think I got it to work, partially: I changed the “firewall” setting of WANT6 to the “WAN” firewall group.

Now, I have one last issue: resolving DNS. I see on ipv6-test.com that I only have DNS4+IP6.

Did you get IPv6 DNS servers to work on your 6in4 tunnel?

Obvious one, but if you are not used to openwert Luci. did you press save and apply at the bottom of interfaces?

Put it in the WAN zone for now.
In Advanced Settings, make sure “Default Gateway” is ticked (on by default).

Make sure IPv6 Routed prefix is the /48 subnet that HE have assigned to you (extra button click to create on their site), otherwise if you do not have a /48 routed prefix from HE, has to be done with NAT, which if you put in the WAN zone, I think will happen.

If you are on Virgin Media (or perhaps other carriers), you need to forward portocol 41 (IPv6) to the MT-1300 router. I just made the GL-MT1300 the DMZ target on the Carrier/Virgin Media home hub, which is overkill but was easier to figure out. Otherwise the router will probably not see responses from HE, so the traffic will not flow.

On your windows PC, type ipconfig and look at the interfacee you connect to you should see a couple of IP6 addresses starting with the routed prefix. If no /48, they will start with IPv6 ULA-Prefi in Interfaces Global Settings (2nd tab).

type ping -6 google.co.uk (I think it is ping6 google.co.uk on a MAC)
Should come back with an IP6 address and pinging it, and it should answer.

After the ping test, if there is still not packets at all on the interface summary for the tunnel.

Check Status, Routes look at the IP6 routes, and make sure htere is a ::/0 entry for the tunnel.

About all I can think of for gotchas off the top of my head.

Simon

Good luck.
Simon

In addition to this, I had to:

  • WANT6 settings → Firewall settings → Add WANT6 to the WAN firewall group
  • Go to the LAN interface settings → DHCP Server → IPv6 settings and change “Router Advertisement-Service” to “server” mode (default is relay mode) (This allows the WANT6 interface to provision IPv6 addresses to clients when the GL.iNET WebUI IPv6 setting is set to “lan mode: Native” instead of “lan mode: NAT6”)
  • Save + Apply the interface settings
  • Reboot the MT1300

Thanks @smiths !

1 Like