MT3000 will not connect to or repeat wifi

Brand new MT3000. Just updated to 4.2.0. It will not connect to some wifi networks.

I have access to two wireless networks, which I do not control.
I cannot connect to either of them. Passwords are correct…I’m posting this connected directly to one of the networks on my laptop. I tried the mac clone, it’s my simple apartment wifi using netgear routers. There is probably no ACL or mac filter.
“Connection failed, will retry later…”

I started the wifi hotspot on my phone, and it connected just fine…

How do we investigate?

If laptop and router both connecting, probably avoid MAC cloning, to avoid tearing your hair out late at night some months ahead. As your phone connects, it would suggest not needed, but good “try” as a diagnostic attempt.

Reboot the router and let it settle.
I am guessing it is not remembering your wifi settings.
So go into Internet, let the scan complete. Do you see the wifi in the list? Do you see 5Ghz or 2.4Ghz or both?

I would try connecting to the 2.4Ghz first, gonna be lousy bandwidth in a shared aprartment, but proves the credntials etc.

If you get the fail to connect, then pull the logs from the logs menu option, it should show the router trying to connect, and hopefully what is going wrong.

Also pop into Upgrade and note the software version running.

Rinse and repeat n the 5GHz channel.

That should allow the really clever people on the forumsee what is happening.


The 4.2.1 Beta firmware did fix a number of issues, maybe try that, Do not Keep Setting to avoid issues.

There is an SSID-Regular (but does not say Regular) and SSID-5G. I’ve tried both. I’ve tried turning off my 2.4ghz and 5ghz radios in various configurations.

Already updated to 4.2.0. I’ll try the beta.

Which log would be useful?
See below for what might be relevant from the System log

Beta firmware update solved it! I can connect now.

Sounds an awful lot like the issues I posted about recently. Unfortunately the wifi was not stable on the 4.2.1 beta code, but I see it is a release 2 so maybe it is better.

I’ve just tried v4.2.1 Beta release 2, as well as 4.2.1 snapshot 28 Mar 2023 on my Beryl AX and DFS channels aren’t working (140 is the last channel visible ). I’ve tested with DE and UK country codes.

Can’t recall correctly, but was this mentioned as already fixed? If so, any suggestions to try?

1 Like

1 Like

I’ve been using it all day with no issues!

I’m doing some research…
I have VPN on my guest network only. Can I block internet on the guest network with the VPN is down? It could go down and I’d guests would never notice…

This is super useful @Aulinho !
Do you mind sharing the source link so we can see the full list?

@alans this is the source of the pic I have put early

@danull @mysticle31

Glinet staff has just confirmed there’s a bug connecting the Repeater to 5G networks when using MAC clone/random.

Turning that off did seem to fix the issue here, how about on your side?

Any more info on this? I’ve just upgraded my MT3000 to 4.2.2. 5G repeater works on one of my APs, but not on the other. 2.4G works on both.

Hi, Can you share more information?
1.What is the AP model that does not work?
2.Does it work before upgrading to 4.2.2 firmware?

The AP model that does not work on 5G is the Technicolor CGM4331 provided by Shaw in Canada:

Unfortunately, I did not try to connect before I upgraded.

Are there error messages in the System Log when trying to connect over 5GHz?

On the XB7 Gateway, what channel is the 5GHz wifi broadcasting on? Is the GL-MT3000 able to scan and see the SSID?

I do not work for and I am not directly associated with GL.iNet

Are there error messages in the System Log when trying to connect over 5GHz?

Here’s is what I can see from the System Log:

On the XB7 Gateway, what channel is the 5GHz wifi broadcasting on? Is the GL-MT3000 able to scan and see the SSID?

Both the XB7 and the MT3000 are broadcasting on 44. Here’s a scan from Wireless Diagnostics on my Mac:

Yes, the MT3000 sees and connects to the XB7 on 5G, then a few seconds later complains that there is no internet access. With 2.4G this does not happen.

(Apologies for the multiple posts. As a new user I can only do one screenshot per post)