MT300N-V2 can't find hotel wifi SSID, and solution

Bought MT300N-V2 a few weeks ago, preparing for a trip. A week ago, I stayed at Holiday Inn in New Jersey for three days. The router scanned wifi in repeater mode, but can’t find hotel’s wifi SSID. My cellphone and laptop were all good finding hotel wifi and connected to it. The SSID is “IHG Connect”. It’s this router that weren’t able to find it. Searched and found a couple posts with the same problem. Wasn’t able to find a solution the first day. The 2nd day, tried many things, finally got it working. Thought I should write it down, hope it’s helpful to other people.

How did you fix it?:slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:

1 Like

Sorry I wasn’t able to reply to any posts. Thanks to moderator Johnex fixing the problem.

Here are screenshots of the hotel’s wifi environment:
Screenshot_20190625-180330_Termux-3

Screeshots from Wifi Analyzer app on cellphone:


IHG Connect signals changed fast, every few seconds, jumping around on different channels and strengths, most of them are hidden:


After found all those info, I did these:

  1. Installed Termux from Google Playstore to my cellphone, for SSH client.
  2. Launched Termux, then installed SSH package.
  3. Connect to MT300N-V2 wifi.
  4. ssh root@192.168.8.1
  5. cd /etc/config
  6. vi wireless
  7. there’s already a section in the file “wireless”, I just updated the last section with hotel’s wifi info. Here’s a screenshot of the updated file:

The lines that were updated under section “config wifi-iface ‘sta’” are these five lines:
option ssid ‘IHG Connect’
option channel ‘6’
option bssid ‘EA:CB:BC:4A:5A:47’
option encryption ‘none’
option disabled ‘0’

From Wifi Analyzer’s results, pick up the strongest signal, use that MAC address to change bssid. Doesn’t matter if that signal is hidden or not, just use that. Also use its channel to update option channel. Encryption is none, since hotel has its own log in web page.

After the file is updated, run command “wifi reload”, or just reboot the router.
The router should be connected to ‘IHG Connect’ now.
I think I let router scan one more time, and see ‘IHG Connect’ showed up. Then let router connected to it. However, I run many scans afterwards, but never see the SSID anymore, from router’s repeater scanning page.

Open browser, try a web page, maybe “http://”, not “https://”. Will be redirected to hotel’s log in page. Fill in info, logged in for the first time. Afterwards, the router should automatically connect to hotel wifi every time powered up.

The first time, I used a MAC address of a weak signal, got very slow speed:
Screenshot_20190625-173924_Speedtest-3

Then realized something, changed to the strongest signal’s MAC address:
Screenshot_20190625-184657_Speedtest-3

Hope that could be useful to people who may get into the same situation.

1 Like

Very useful testing and results – It seems that the situation is triggered by this apparent “hopping” of the visible SSID from channel to channel. Guessing, there is some kind of capacity management in place, where the hotel’s network of APs selectively advertise themselves.

Cellphones and laptops have no problem finding the ssid and connecting to it. It’s this particular router having this problem. My guess is some pieces of code are stripped off from the firmware for this router, which caused this problem. Hope developer can find a solution for it.

Another use case that these travel routers can’t work at all is, the AP requires the user to download and install an app for each device, and configure each device for the user’s specific login/password. A typical example is ‘eduroam’ that’s available at most universities, for their students/staff, etc. These routers can’t connect to eduroam at all, since there’s no way to download/install the app to the router.

You might want to try 802.1X authentication to Eduroam. It may require the wpad (full) package if not already installed on your device. Doing so will require removal of the wpad-mini package and it unfortunately conflicts with the wpad-mesh package which is required for SAE for 802.11s.

Thanks for sharing.

Does your Phone or laptop can see those SSID without WiFi analyzer?

I saw your screenshot, it seems all IHG Connect is hidden SSID.

Both cell phone and laptop can see one SSID “IHG Connect”, and there’s no problem connecting to it. The router at reapter mode, scanning wifi doesn’t see that SSID.
Not all IGH Connect are hidden. Most are hidden, a few are not. They jump on different channels at pretty fast rate. Hidden and non-hidden SSIDs change channels / signal strength frequently.

RE: the IHG Connect SSID hopping all over the place

This is to prevent exactly what you’re doing here :slight_smile: Most phones and laptops deal with it fine, but they don’t like people doing what you’re doing so the commercial/enterprise vendors have come up with neat little ways to prevent it or at least raise the bar to entry.