MT300N-V2 scan for Wi-Fi fails after 3.201

After an upgrade to 3.201, I am unable to scan for any hotspots to connect to for internet. Either there is no dropdown on completion of the scan. Or the scan times out at 99%.
I have my phone, with hotspot active next to the router. Also my phone, and 2 tablets all show multiple wireless networks nearby, that the router never finds.
Also, after the scan times out, I lose contact with the router and have to reboot it to access again.
Can this be reflashed back to 3.105, as that worked perfectly.
Any ideas.

Not sure why. But you can download 3.105 and flash back.

Can you also try these?

  1. Open browser debug mode and check console output. In windows + Chrome, use F12

  1. SSH to the router and scan manually and get output?
iwinfo ra0 scan


Segmentation fault


Just a data point. I dragged out my Mango and set up my Pixel 3 as a hotspot. I had no difficulty connecting a laptop to my Mango, and then scanning the area and seeing my router SSIDs and my Pixel 3 hotspot, joining each in turn and having my OpenVPN client connect to its server. All without rebooting anything.

No issues ssh into the Mango and running iwinfo.

I’m not sure the use case here. If I am using my Pixel 3 as the internet connection, I think I would just connect my wireless devices directly to it. If I needed to connect a lot of devices and wired devices, I think I would just tether it so the wireless is in AP mode, rather than AP+STA.

@alzhao Any ideas.

When I did the upgrade I was careful to un-check the “Keep settings” option.


I understand. are you able test in some other place, where the surrounding networks are different?

May be caused by some some SSIDs with strange info but as it is segment fault, difficult to proceed to troubleshoot.

Not easily, no.

I’m just going to reflash back to 3.105 which doesn’t exhibit this issue, even in the same location, and so the same networks.


Developers seems to have found the problem. Pls wait for a testing firmware.

Is this fixed in the 3.203 Beta releases.


1 Like

Can you try and let me know? If still does not work I will call expert to chekc.

The previous scan error appears to have been resolved.

However I cannot install Luci. The Install button never becomes active.

Also I get a “Parameter not found” error trying to start a Wireguard VPN. I’m fairly certain I reported this same error some time ago on a previous upgrade, but can’t find it at the moment.


About wireguard vpn server, pls check

I think it is a problem brought up from upgrading.

A clean install of 3.203 should have fixed this.

Sorry, I should have been clearer. This is a Wireguard client. Well, actually multiple Wireguard clients. They import, via cut/paste into the configuration window, correctly but then throw the error trying to start. Also, trying to delete a single configuration throws the same error. The only way to reload is to use the “wipe all configurations” button.

If by this you mean un-check the “keep settings”, then that’s exactly what I did. Or are you suggesting it should have been a UBoot install.

BTW This was the beta4 snapshot.


This is getting beyond a joke now.

I just downgraded back to 3.201 as I need the VPN more than I need the wireless connectivity. Well, after downgrading I don’t have the wi-fi scan issue I started the thread with. Hmmmm, strange.

But, I still have the Wireguard issue that started with 3.203, despite Wireguard working perfectly on 3.201 before the upgrade (and downgrade).

I’ve just spent a couple of hours trying to sort the Wireguard client issues out and here’s a bunch of random thoughts.

After installing any of, 3.105, 3.201, or 3.203 (beta4) via the UBoot process to ensure “cleanness” and doing no other configuration changes whatsoever, then uploading a Wireguard configuration in the Web Admin configuration panel and trying to start the client fails with: ERROR: No parameter found. No matter what I did, I wasn’t able to get a working Wireguard client via the Web Admin configuration panel. Typing in the configuration via the Manual Input panel had exactly the same issues.

So, switching over to the iOS app and uploading the configurations there, appears to work, but has some strange side effects.

You can load as many configurations as you want, even with the same name repeatedly which doesn’t overwrite the existing one, but once loaded there is no way (that I’ve seen) to either view the configuration or to delete it.

Until you use the app to start a client, none of the configurations loaded in the app show up in the Web Admin panels. Once the client has been started, that particular configuration now shows up in the Web Admin, where you can now view the configuration and even delete it. But, guess what, that doesn’t delete it from the app, where I still have multiple configurations with the same name.

Starting a different configuration, in the app, updates the Web Admin to only show the new one started, as it replaces the one in that panel that was previously started. So you can have multiple configurations, but only if you use the app to start them.


Can you paste the wireguard config? Maybe you can just send to me via private message so that I can try.

Recent firmware only fixed a problem in wireguard server, not wireguard client. So it is not your issue.

For smartphone app: app can manage vpn profiles much better than the router. So it only push the one in use to the router, rather than push all the profile to the router.

PrivateKey = KCM…IVs=
Address =

PublicKey = MZ3…oAo=
AllowedIPs =
Endpoint =


PrivateKey = KDL…/FI=
Address =

PublicKey = rrA…HxU=
AllowedIPs =
Endpoint =

That’s a matter of opinion.

  • App has to be connected via Wi-Fi. Router only needs IP connection
  • App allows upload of multiple configurations with the same name
  • App does not allow viewing of configuration
  • App does not allow deleting of configuration


Can you add this line to [peer] section?

PersistentKeepalive = 25

App has its advantage. The biggest advantage is that it is interactive and can manage profiles easily. It has drawbacks though.

Sorry, same message: ERROR: No parameter found!