MT6000 broken with 4.5.7 upgrade

Updated MT6000 with 4.5.7 - which was marked as stable - and router stopped responding. Powercycled etc. No luck. Needed to reset to factory settings and needed to spend some time on setting things up (good that have all DHCP, DNS, firewalls scripted), but that kind of things shouldn’t happen.
Today I noticed that this version has been revoked from support center:

From which version did you upgrade? Did you keep your settings?
(Which is generally not advisable when switching between Beta ↔ Stable)

Was on stable 4.5.6 , had settings kept . And yes trying to check if it somethow brought back to defautls: but not response: gl.inet wifi not visible, no dhcp assigment on any port, also set PC IP to and and tried to reach by “default” ip: no luck. No packets detected on desktop.

4.5.7 is draw back because of some bugs, e.g. Ethernet speed, luci etc.

But it should not break your router. Not sure what was the reason.

So maybe stupid question: is there any “save settings” option to save all configs in external file?

In luci (advanced settings) you can back up the settings.

1 Like

Your best bet it’s restart to factory defaults and setup from scratch up

1 Like

Using 2 MT6000 routers. Upgraded to 4.5.7 and it was complete disaster. Wifi settings were no longer visible in the GUI and a lot of connection instability issues.

Just came across this thread to only see that 4.5.7 has been removed.

Please read this statement: Updates on Flint 2's recent firmware version: pulling back v4.5.7 and releasing v4.5.8 soon

Thanks admon for the link to the issues w/ 4.5.7. Since I’m still having a lot of disconnect issues both with wired and wireless connections, would it be best if I downgrade both of my MT6000 routers back to 4.5.6???

Can’t tell for sure because it’s unlikely that the firmware causes the wired connections to have issues. Maybe you should create a new thread about your issues while following How to get support quickly

I downgraded to 4.5.4 from 4.5.7. I haven’t experienced any disconnection issues with that older version.

1 Like

You get this disconnects via wifi or ethernet as well? I can’t tell abbout wifi as gl.inet using as frontend only (Unifi switches, access points are connected via ethernet)

I was on 4.5.6 and really never experienced any ethernet or wifi disconnect issues. After upgrading to 4.5.7 it has become a disaster! Ethernet connected devices disconnect and or take a long time to load pages. Wifi remains connected to my smartphone but w/o any internet connection. Phone also reports that wifi is connected without internet.

As far as I can tell, nothing gets disconnected at all (wired and wireless) on 4.5.4.

Thanks for the tip. Tried 4.5.4 but seems unstable and still getting lots of wired and wireless disconnects. Went back to 4.5.6 and things seem more stable but wireless speed are slow. Eg 26.8mbps / 6.88mbps. Use to get around 500/500.