MUDI + AT&T in USA

I heard Mudi doesn’t work with AT&T in USA now. When can it be fixed?

Did anyone tried Mudi + AT&T in USA?

I’m on an AT&T MVNO and I have successfully connected. I’m currently only getting 3g service, I think that’s probably a frequency availability issue with the Mudi. I tried to manually configure the APN, reset the modem…didn’t seem to work. Then I put in an inactive secondary APN that I found on my phone, reset…didn’t seem to work. I then put in my cellphone number into the manual configuration and hit auto configure and reset. A few minutes later, I was connected. Not exactly sure which one of those worked…

I also got 3G working on AT&T. but we need LTE working, correct?

Can you make sure you got an American version? The UI shows the model of the modem. Can you give a screenshot?

If you used a version not for the US you will get 3G network.

See attached

by the way, with the above settings, I still don’t get data connection to AT&T (even 3G). The sim card works (it is a unlimited iPad plan sim card by AT&T, not a MVNO card)

If possible, can I help you remotely?

Yes. That will be great! How can I setup the Mudi to get your remote troubleshooting?

It seems that your APN is not correct, the Nighthawk MR1100 use this APN:

1 Like

but it shows ‘3G’, which means the U.S. version of MUDI, with EC25AFF doesn’t event have the right band for AT&T, correct?

by the way, by changing the APN to ‘broadband’ and reboot. AT&T works now! Thanks!

Showing 3G does not mean it does not have the right band.

Glad to know!

I wrote a post here where you can follow the steps and try to solve the problem

Are you getting AT&T LTE service now?

Has anyone had any luck with the EP06A?(EP06ALAR02A07M4G), shows 3g with no connection(apn set to broadband). This same card works fine with lte in my nighthawk.

Yes. I confirmed EP06A works (I bought a US version of MUDI with EC25AF, then I swap it using a EP06A).

You just need to follow the instruction above. device is /dev/cdc-wdm0, APN to ‘broadband’

then reboot.

it worked for me.

Have you tried the method in the link? AT&T network fix

step two doesn’t target the ep06a, R02 is the version string on it. R05/07 are what the second part of those instructions are for. @ken555 I have had it set to broadband since I got it. No dice.

For EP06, execute at+qfopen="../../data/fota_ip_a/update_report.ur",1