Mudi e750 wireguard client issue


i am facing similar issue to GL-AR750S Wireguard client cannot connect to external wireguard server where i am unable to connect my mudi wireguard client to an existing wireguard server.

have verified the credentials are all working fine on an android and ios.

upon executing wg0 in ssh … result is empty

please assist

can you connect to Raspwg server with anything other than 750s?
if so, is that your working client config from that client?
if so, did you stop the wg client from that client before connecting with 750s? :wink:

Yes, you can’t have multiple devices use the same wireguard client config. Each device must have it’s own config, this is easy to miss and can cause strange issues. Might work sometimes but mostly not.


Yes created a unique account for mudi e750 after testing other accounts with my iOS and Android.

But as I was having problem connecting the mudi as WG client, I replicate the credentials to my iOS which works fine too. Please refer to attached

cool. now lets look at it from a question of network connectivity. can you, using your original wireguard client machine, connect to your mudi and then connect through the mudi to the wireguard server with a wireguard connection to resolve resolution issues or firewall issues.

(in know wireguard is a peer to peer but using client and server makes it a little easier to discuss)

hi rp201rp,

appreciate your continued assistance; please refer to attached multiple test case results.


From your screenshot, you can see that without the enable configuration, you can ssh to the routing background, then modify the enable to 1, and then execute /etc/init.d/wireguard start in the background.

If there is still a problem, please /etc/config/wireguard, /etc/config/firewall and /etc/init.d/wireguard send me a copy of the file, and use the logread command to send me the output information

hi, tried the steps but no luck on getting connected.

i have retrieved the logs and configs. how should i forward them to you?

You can email me log and configs, my email address:

Hi, requested files sent via email.

Thank you.

you are showing your wg client config for the mudi.
can you post the client config from ios. android wg client has an export function not sure if ios has one. of course block keys and endpoint

Hi , I used the configuration you sent, and the wireguard client connection using my android phone was also unreachable, and it was not able to connect on the router. You can use the configuration you sent me, and try with your android or ios device I guess there is a problem with the configuration, is it the wrong key?

Hi, i re-created a new entry in Mudi E750 with setting provided with WG server on Raspberry and this time it works (see attached screenshot for future reference) but only for “AllowedIPs =” and NOT "AllowedIPs =,

Same behaviour for Android and iOS, where i get bad tunnel address error when AllowedIPs set to internal/private only.

[update #1] On iOS even on full route, a DNS entry is required.

[update #2] for trial & error, on iOS for split … setting the WG server IP (in my case as DNS seems to work but not for mudi E750 or Android.

My server config screenshot to follow in next post due to limited permission for multiple picture in 1 post.

Thank you all.

My WG server config running on Raspberry.


You can modify AllowedIPs as follows:

Yes i did, and it does connect but only able to access those private IPs range; no internet at all.

Also, when manually creating WG client in mudi e750, it does not allow input of 2 subnet during creation but you may add on on existing profile under Management page

We email communication, if I can see it remotely through teamviewer

hi gl, thanks you helping out yesterday. what i am trying to achieve is per attached.

appreciate your assistance once again.

1 Like

I will contact you via skype and give you remote assistence