MUDI (GL-E750 w/ EP06-E) slow 4G/LTE speed

I just got my GL-E750 today after a couple of months waiting, unboxed it and plugged in a SIM card. Out of the box the device only gets around 20Mbps up and down on LTE (tested using ethernet off course). This is extremely worrying, since the same SIM card in another device in the same spot gets up to 80-100Mbps! Also my smartphone can reach the same speeds. All tests done on same mobile network.

Reading the forum I read that some users changed the bands and got it working with better speeds.

Here’s the output of some AT commands:

AT+QNWINFO

+QNWINFO: "FDD LTE","20205","LTE BAND 3",1451

OK

AT+QCAINFO

OK

AT+CSQ

+CSQ: 31,99

OK

Is there any way I can get better speeds on LTE? The mobile network in my area is more than capable (5G also available).

EDIT: Just checked, my smartphone is on the same band (both devices on band 3)

I’ve updated fw to latest version but speed was still very slow. Restoring factory defaults after fw upgrade got the speed up to ~33Mbps down and ~45Mbps up! It’s a big improvement, upload is the same as any other device but download still lacks a lot.

The Mudi is LTE Cat 6 wereas your phone is probably more.

During your speedtest you can execute the AT command AT+QCAINFO
that will show you carrier aggregation status.

On your phone you can use the app RNCMobile on Android which will show you the carrier aggregation that it’s making and then compare. Your phone probably aggregate 3 band and only 2 for Mudi.

You can also try qcm mode in modem settings which should improve speeds.

It always returns “OK” even if im stressing it or staying idle, but I remember it returning two bands (3 and 7) once. It’s in the same position for all my tests :thinking:

That’s weird… Do you have good reception on both bands ? Higher frequency bands have trouble reaching into building and reach less far than lower frequency bands

Maybe try to reset the modem if you’ve played a lot with AT commands

Just post your modem config please.

Try using device cdc-wdm0 and qcm as protocol. Check the speed.

I’m starting to believe that its a reception issue. Not actually an issue, but I believe the MUDI can reach less towers.

cdc-wdm0 is what unblocked it from 20Mbit to ~35Mbit actually. I have also changed to cqm from auto and doing some tests.

EDIT: I did some tests with cqm. Ping went from 19ms to 17ms. Download from 34Mbps to 38Mbps, upload from 40Mbps to 44Mbps. It’s a good improvement but I believe it can get better :thinking:

What file do you need me to post? Just a screenshot of modem page or a file in /etc/config?

Resetting the modem through the web UI doesn’t really work from what I can understand. I had set the band to 3 and it didn’t reset when I run the AT preset “Reset modem” (AT&F0) from the UI.

This one below and a reboot brought back CA!

I’m now at 45Mbps down and 20Mbps up which is a bit nicer, but still a bit far from the advertised CAT6 speeds :thinking:

I mean screenshot. But now you have well explained.

Also try chaing ttl

1 Like

Any ideas what value should I put? I tried 64 and got up to 50Mbps. Not sure if related though or maybe just temporary

Try to put 65 and check

Same speed, now I’m starting to see packet loss up to 10%! :cry:

… don’t know why even lower

Not a 4G/LTE guru, but in cell info I can see cell tower speed as 20down and 20up. In CA I can see two towers being used so 20x2=40Mbit? It makes sense, but its a very wild guess :thinking:

It also depends on the band width you have on those bands. 300mbps is on ultra ideal conditions on 2 20MHz aggregate bands.
What’s the width ?

This is the bandwidth of LTE, not speed.

To calculate the speed, check How to calculate LTE throughput

Google give a simple answer: the with 20Mhz you can get max 100.8mpbs

Yes you are correct, I misinterpreted the information. For the time being I’m happy with the speed.

I managed to get up to 45Mbit down and 45Mbit up (normal speeds are a bit lower but thats ok)

1 Like