My router doesn't recognize the hard drive I connect

Good morning.
I am using a GL-MT300N.V2 (Mango) model that doesn’t recognize the hard drive I plugged in the USB port that the router has.
The first time I run the file sharing plugins it works fine but then, when I turn on the router later, the path of the file that was sharing before does not appear. Every time I try to login through my computer or any other device, just show an empty file with no permission.

Here I upload some images just to show you what kind of problem I have.

Thank you for your time.

Tomas Ospina.
Captura de Pantalla 2022-03-26 a la(s) 2.32.0 7 p. m.

Can you ssh to the router and check using these comamnds:

ls /dev
ls /mnt

Is it an SSD? If not perhaps the USB port isn’t supplying enough power?

Is not. I use a HDD, at first I thought it was an energy problem as you said, but once a time the router works perfectly and recognize de driver, then when I turn off I unplugged the driver, upload some files, plugged in and then turn on the router but then the router didn’t recognize it.

I have found that spinning HDD’s sometimes work and sometimes not, due to limited USB 2.0 power, but SSD’s and Flash drives always work.

I do not work for and I do not have formal association with GL.iNet

For HDD you should use separate power.

If worked one time does not mean it works OK.

When you have problems, do as I suggested in this post to find the problem.

I tried that, I also use an old HDD who was powered by an 12V cable, different from the USB cable and didn’t work. But I noticed something, it seems that every HDD who has a 3.0 USB output reboot the router, and when the router tries to initialize the main config, it tries to read the data form the HDD because it sounds how the disk of the driver tries to run but failing.

I believe that too, but I don’t have any SSD to try on. Also, I needed to work with the HDD because is an old driver that nobody was using.

I did that plenty times before, sometimes the router read the driver but other times not.
Also when the router read it and I share some file from it, the clients show up that they didn’t have the right permissions.

Yeah. I think that’s the problem. I want to give back this router and search for someone who has 3.0 USB port.
Any suggestions?