New Firmware?

Update: While a working config gets carried from v2.25 to v2.254, as soon as I try to update to a new network, the working config gets overwritten with a non-working one…

I loaded a virgin copy or 2.254 and can confirm wirless connectivity problems and no internet.

@Glitch @kedalion @khaberz thanks all for testing. Will fix asap.

Hey, on the test firmware it mentions custom dns on VPN switch, how do I set different DNS for regular vs VPN connection? Is this possible?

2.255: tested without reserving (saving) settings: mostly functional but I couldn’t change the WiFi from 54M > 300M (I did manage to change it to 150M).


@alzhao: I see you used a new version of wpad in v2.255. It seems to be fine and I can successfully connect to all the WPA2-EAP networks now.

I have to set up credentials through LuCI though. The main GUI does not offer any way to set it up. I also managed to manually add/adjust the network information in ‘/etc/config/ssids’, and they show up in the GUI list. With limited success: some fields such as ‘identity’ and ‘password’ don’t seem to be used or updated correctly. (I added to WPA2-EAP networks, but switching between them does not work. The identity and password that should be updated in ‘/etc/config/wireless’ remains the same. Likely I once set it with LuCI and it is never been changed by the GUI.)

I assume the program that converts the info in ‘/etc/config/ssids’ to ‘/etc/config/wireless’ was never expected to handle the additional fields. Just in case, here is what I had added to the ‘ssids’ file (mostly info how it worked in /etc/config/wireless).

config network 'sta1' option ssid 'eduroam' option mode 'sta' option ifname 'wlan-sta' option eap_type 'ttls' option auth 'PAP' option identity 'XYZ' option password 'mypass' option wds '0' option encryption 'wpa2'


Eduroam is used in Universities all over, having the ability to connect to these networks would make GLI a great purchase for students.

WPA2 Enterprise would probably be more useful than USB Hotspot etc.

2.257: seems to work OK, no problems found.

Can I request the warning pop-up > Luci can be disabled (ie. “do not show me this message again” check box).


2.26: lot’s of problems, Wifi, Lan both intermittent. Found it very hard to get back to 2.257 because could not easily access web interface (no Lan or Wifi)!


really!! which model are you using?

AR300M - tried it in both of mine, both the same. Using it as a repeater on Wifi wouldn’t start, LAN had trouble being identified. Reset button did not repsond.

Then had problems with Uboot - had to keep reset button pushed while connecting power until all LED’s flashed and router appeared to reset (firmware 2.20!). Then managed to login, reset and finally re-flash.

Actually I spend whole weekend to compile a firmware that doesn’t run. I put it on the testing folder but deleted it after found the problem. I then recompile and put it on the web but the name is still 2.26. So I think you downloaded the one that doesn’t boot.

Now the firmware for AR300M has been published in its own folder. Can you redownload and upgrade? Please don’t keep setttings.

LOL, please don’t do that again (different firmwares with same number)!

I will try and report back.

v2.26 working smoothly. I also tested the new AES-GCM cipher in OpenVPN 2.4 as well. I used the TAR file in: GL.iNet download center

Thanks alzhao!

Hi Alzhao,

I found an alert on my AR300M web UI for a new firmware (2.26). I tried to install it twice, but i get always the old one version (2.25)


@nikor: the issue might be because 2.26 in GL.iNet download center is listed as openwrt-ar300m-nand-2.25.tar instead of openwrt-ar300m-nand-2.26.tar

Try downloading GL.iNet download center and manually upload it on the flash firmware page.

Thanx jackiechun, it works

OK, downloaded and set the “new” new 2.26 version and mostly fine (as with 2.257).

  1. I had to login via LAN and reset my wifi password (previously defaulted to UI password, I believe).
  2. Thanks for adding the option to disable UPnP (perhaps it should be diasbaled by default).
  3. I would still like to default wifi zone to be anything other than the US (eg. 00) as my main router is on channel 12.
  4. My repeater setting in GL UI shows “fixed by repeater” (channel 6) even though it is actually channel 12. Also, logging into Luci, it confirms this conflict (router on Ch.12 / operating frequency Ch.6).
  5. I would request a “don’t show this message again” checkbox when accessing Luci.
  1. I am not sure why this happens. You surely should be able to setup using wifi

    1. We will fix this later.
  2. Because it is only one radio, you cannot change ap channel when using repeater.

  3. Now it is just a very simple confirm box. Maybe you can just use your middle mouse key to bypass this message.

Hi Alzhao,

I’m using AR300M as WISP mode repeater, so I should not see devices outside my subnet in addition to the master router ( Why is this happening here as you can see from the attached photo?

Thanx in advance…

P.S.: Obviously WAN access disable, UpnP disabled