New to the GLiNet can not see the USB or micro

I just got aGL-MT1300 and put the microSD card in. I can not see it even though I have rebooted several times. I tried a USB, and I can not see that either. The USB worked in my old MT300.
Is there a guide for how to mount these drives or should it work. I can connect to the file share but I see only Record and Time_lapse - I am assuming that they are the internal storage.

what firmware are you using?
If you use the firmware v3.x, then perhaps you should confirm the installation of FILE Sharing in the Glinet interface Applications>File Sharing > File Sharing Install (this requires an Internet).
Could you please share a screenshot of this settings with USB/SD Card in?

To confirm, you are able to connect to the microSD card? I think the router uses “GL-Samba” as the default share name. If so, can you check if “Record” and “Time_lapse” are file/folders on the microSD card?

You can also log into the router via SSH and run the following commands:

This will show all the mounted devices -


This will show the contents of the microSD card mount point -

ls -l /mnt/mmcblk0p1

Here is the official GL.iNet documentation on File Sharing for your GL-MT1300:

I do not work for and I do not have formal association with GL.iNet.

Can you give a screenshot of “Time_lapse”? Not sure what it is.

Sadly I can not SSH into the router… something in the config must be wrong…
Unable to negotiate with port 22: no matching host key type found. Their offer: ssh-rsa

You can download the free PuTTY at It will allow you to accept using without the host key.

Just search for:

It will get some answer, for example: Ssh issues - #2 by LupusE

One time:
ssh -oHostKeyAlgorithms=+ssh-rsa root@

echo -e “\tHostKeyAlgorithms ssh-rsa” >> .ssh/config

The error says “I ask for a set of ‘key types’, none is okay for the host. It demands ssh-rsa”. And oHostKeyAlgorithms=+ssh-rsa adds this ‘type’ to the offered choices.

Did you unmount the card properly before moving it? might have corrupted the data.
Did you format the card on a computer before trying to mount it on the router?