"No Internet Connection! Find a network to reconnect" message, but almost everything works

Hello, I am new here and Flint 2 is my first router from GL.iNet. I set it up behind my ISP router via LAN within the same network. Everything seems to work (even the Wireguard server using port forwarding from the first router). The problem is that I'm getting a "No Internet Connection! Find a network to reconnect" message, and some things don't connect, like plugins with the alert "Failed to update repository list, please check your network and try again."

Everything else (Wi-Fi, Dynamic DNS, AdGuard) works fine. I tried the latest stable, beta, and snapshot versions with the same results. Any thoughts?

BTW am I getting 200MB/s with a SSD attached via Samba in case anyone is interested.

Thanks.

Are you connecting via LAN port to your ISP router? This is wrong.

You should connect via WAN port to your ISP router.

Thank you alzhao.
The problem with connecting via WAN is that I want to avoid double NAT issues. The ISP router doesn't allow bridge mode or even static routing. Do you know any solutions to fix the connection issues in LAN mode?
Regards

If you want to use as Wireguard server you should let it work in router mode.

Do you mean by using “Drop-in gateway” option?
Thanks.

NO. Drop-in gateway mode is for VPN client or Adguard Home etc.

For VPN server, the router should just work in "Router mode".

Good morning, I received the same router yesterday and configured it the same way. I want it to function as an access point (to provide WiFi coverage in that area of the house on the same network I already have) and connect a NAS to one of the 2.5 Gb ports. Additionally, I use it to create a VPN with TailScale.

Everything works perfectly. Even when I go to LUCI, I can confirm that it has internet access without any problem. However, the GL.inet GUI shows the message "No Internet Connection! Find a network to reconnect." It's a visual annoyance since it works and has internet access.

I just want to remove that message, since it's not true.

Thnak you in advance

LAN: 192.168.10.0/24
4 phones, 3 computers, 9 IoT devices, 1 Nvidia Shield, 2 printers, 3 access points, 6 WiFi security cameras, 3 smart speakers, and I think that's all.

Model: GL.iNet GL-MT6000
OpenWrt Version: OpenWrt 21.02-SNAPSHOT r15812+1071-46b6ee7ffc
Kernel Version: 5.4.238

Sounds like a bug.
Is your Flint 2 working in Access Point mode or Router mode?
If it is in Router mode, you can disable Enable Interface Status Track or modify Track IP in Multi-WAN.

Router mode

After changing it and restarting...

I don't know where to change "Enable Interface Status Track," I can't find where to do it.

On each interface after clicking :gear:

That's what I changed; all four are like that now.

You indicated 2 options: "you can disable Enable Interface Status Track or modify Track IP in Multi-WAN." I understand that the one I used is "modify Track IP in Multi-WAN," and I don't know how to change the other one; I can't find where to do it.


Both here, just need to execute the one of 2, he said 'or'

Understood, but it still doesn't remove the message...

Aha.. Could you please show us with some screenshots of the router related configuration and this message?

If you specify which configuration screens you want, I'll send them to you, no problem. This is what I understand you're asking for.

(post deleted by author)

(post deleted by author)

Hello again,
I tried the same things with no luck, at the end I used WAN instead LAN and that was the only way to avoid the message. I'm using a different subnet and it seems that works fine everything I need.

Javier, with LAN connection, Can you install plugins? That was the only issue besides the error message.

Thanks for your debug guide, we will fix it refer to your idea, but let us evaluate if this is the best way.